Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have switched my programming environment from Windows 7 to Mac OS X Lion, and I missed the Windows' crispy front rendering, for example, under Eclipse, you can check the screenshots.

OS X:

Windows:

Of course there are differences in font family and size, but the Windows version seems has better font rendering.

Are there any setting in OS X I can improve the typography?

share|improve this question
1  
Apple love that anti-aliasing method so much that they hammered it into Safari on the Windows platform: joelonsoftware.com/items/2007/06/12.html and codinghorror.com/blog/2007/06/… –  Mark Henderson Aug 7 '12 at 1:50
1  
@MarkHenderson Newer versions of Safari use native text rendering on Windows. –  Lauri Ranta Aug 10 '12 at 10:35
    
For those wondering why there's a difference, the short answer is that OS X's rendering values fidelity to the typeface over crispness, whereas Windows' rendering values crispness over fidelity to the typeface. The ultimate solution is to upgrade to a Retina display, where antialiasing becomes moot. –  Spiff Aug 13 '12 at 9:54
add comment

4 Answers

Some time ago, while preparing a presentation for a client that was to be viewed using a Mac, I've faced the same issue.


Tweak

A simple tweak to the anti-aliasing improved the rendering of fonts for the monitor used:

  1. Open the terminal: Applications → Utilities → Terminal

  2. Type:

    defaults -currentHost write -g AppleFontSmoothing -int 2
    

    You can uses numbers between 1 and 4. Four is the default one.

    For me I've got the desirable result using the value two.

  3. Restart the OS.


Comparison:

I didn't performed any comparison, but users from the link bellow have compared the improvement using Chrome.

  1. Used chrome and load a website on the first tab;

  2. Apply a difference value from the above command line reference;

  3. Open a new tab a access the same website;

  4. Compare by looking at both tabs side by side.


Credits:

Credits on this solution to: tonymacx86 at http://tonymacx86.blogspot.pt.

share|improve this answer
add comment

System Preferences had an option to use a lighter text rendering style, but it was removed in 10.6. You can still use it by modifying property lists though.

defaults write -g AppleFontSmoothing -int 1
sudo defaults write -g AppleFontSmoothing -int 1

The second command is needed for windows shown by processes owned by root like the force quit window.

I've always used the light setting. It's closer to the weight of printed text and makes especially Japanese text and light text on a dark background look better in my opinion.

Eclipse doesn't seem to support subpixel rendering on OS X, so text might look different in it than in native applications. I can't tell it from the screenshot, but check if LCD font smoothing (subpixel rendering) is enabled.

If clicking the checkbox has no effect, it might be because subpixel rendering is not enabled automatically on some LCDs. Setting AppleFontSmoothing to 2 or 1 might force it to be enabled.

share|improve this answer
    
How good to have my fonts back! My head was exploding after just a few hours of coding with the awful smoothed text on PyCharm. I still don't understand why there is no setting for this in the preferences (Using Apple Display 22", but had to run the defaults command). –  AJweb Oct 10 '12 at 13:55
add comment

There are a two settings in the System Preferences > Appearance pane.

If you change the size at which font smoothing is turned off I think it will look sharper.

There is an option to turn LCD font smoothing on/off but I can't see a difference, I think it's sub pixel smoothing on LCD screens, so probably screen specific. I have it turned off.

share|improve this answer
add comment

Although you cant turn off the font smoothing on OSX you can try a few things to mitigate it

Coping with OSX font rendering

There is also an Apple Support article that deals with this issue too.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.