Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On iTerm on OSX Mountain Lion the default Monaco font is not very good for white on black text

Aliased text is ugly

enter image description here

Anti-aliased text is too bold

enter image description here

I would prefer more crisp anti-aliased font. So...

  • Are there better fonts one could use?

  • Is there way to tune font so that it doesn't look ugly

This is on 1920 x 1080 external monitor, so I am not sure if it does subpixel anti aliasing.

share|improve this question

4 Answers 4

up vote 16 down vote accepted

System Preferences used to allow choosing from two additional text rendering settings, light and strong, in 10.5 and earlier. I've always used the light setting. It's closer to the weight of printed text, but characters still have smoother edges or aren't as pixelated as on Windows.

You can still use the old settings by editing property lists:

defaults write -g AppleFontSmoothing -int 1
sudo defaults write -g AppleFontSmoothing -int 1

The command with sudo modifies /var/root/Library/Preferences/.GlobalPreferences.plist. It's needed for windows shown by processes owned by root, like the force quit window.

Monospace fonts are often the same width at for example 13 and 14 points, but the smaller size appears lighter or to have more space around the characters:

I've posted a comparison of Cousine, Droid Sans Mono, Inconsolata, PT Mono, and Source Code Pro at Ask Different.

share|improve this answer
    
O/T: Can I ask you how you created the GIFs? –  slhck Aug 4 '12 at 19:22
2  
for f in *.png; do convert "$f" -flatten -pointsize 20 -gravity south -annotate +0+25 "${f%.png}" "x$f"; done and convert -delay 200 x*.png output.gif. There's also some ImageMagick examples on my website. –  ؘؘؘؘ Aug 4 '12 at 19:36
1  
does this still work? I'm on 10.8.2 and I can't see any difference after running the defaults write -g AppleFontSmoothing -int 1 command. Do I have to reboot? –  Anentropic Jan 15 '13 at 15:47
    
@Anentropic You just have to reopen applications. If defaults -currentHost read -g AppleFontSmoothing exists, it has precedence over defaults read -g AppleFontSmoothing. –  ؘؘؘؘ Jan 15 '13 at 16:05

Menlo is good, but with the way subpixel antialiasing works with white text on a black background, you could either inver that, or turn off "Use LCD font smoothing" in System Preferences under General.

share|improve this answer

On OS X 10.9 (Mavericks), you can get a nice crisp console font without changing the text rendering settings. Simply select Monaco 10pt font and uncheck "Antialias text" inside the Terminal.app settings (or select the included "Pro" profile, which already has these settings applied).

If you're using iTerm.app, you can do the same thing: select Monaco 10pt font and make sure "Anti-aliased" is unchecked.

OS X 10.6+ removed the font rendering settings from the System Preferences panel, but many apps now directly include the option to disable anti-aliasing, including Terminal.app and iTerm.app.

share|improve this answer

Disable "Draw bold text in bold font" (under Text tab) also really improves the looks.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.