Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Got a strange issue at the moment where a PC I'm trying to fix isn't connecting to the network. I've booted from a "Mini Windows XP" boot CD I have and the ethernet connects immediately and works fine, then when I boot back into Windows Vista, it won't connect again.

Device manager shows the network card and I can change settings etc, but it just won't connect (red X).

When I try and "repair" the connection it just says Windows cannot repair this problem automatically.

I've reinstalled the drivers and still get the same issue.

Anyone got any ideas on what else I can try? :/

share|improve this question
    
When you go into Properties for the network adapter in Network Connections, make sure that the checkbox for TCP/IP is checked. You definitely need version 4, but you can try playing around with checking version 6 too, as well as things like Client for Microsoft Networks. Within the properties of the TCP/IP driver, make sure you don't have a static IP address set up (unless you know you need one, which is unlikely considering the live CD just works). If you have a static IP configured, set it to automatically determine the address. –  allquixotic Aug 3 '12 at 20:19
    
Yeah I've tried all that, and everything is set to automatic (same settings that work on mini xp) :( –  BT643 Aug 3 '12 at 21:11
    
Have you simply tried turning the adapter off and on? –  ekaj Aug 3 '12 at 22:36
    
Yup, no joy with that either. –  BT643 Aug 4 '12 at 2:25
    
Does it work in Vista's Safe Mode with Networking? Have you tried installing another network adapter to see how it functions? Have you ensured all hidden and disconnected NICs have been removed? How about a System Restore to a point when it did work? –  Ƭᴇcʜιᴇ007 Aug 4 '12 at 17:21

2 Answers 2

up vote 1 down vote accepted

I gave up and reformatted with Windows 7 in the end, that sorted it. So not sure what had gone wrong! Thanks for the replies.

share|improve this answer

Did you install the right driver? Just because Windows Vista selects a particular driver does not mean it is the right one.

For example, my computer has a Realtek RTL8111C gigabit ethernet controller. When I initially installed Windows Vista, Windows tried to use the (incompatible) RTL8111B driver, so "8111B" is what showed up in Device Manager. Installing the driver from the CD that came with the motherboard fixed the problem.

share|improve this answer
    
Yeah I grabbed the drivers from the Dell page (putting in the specific service tag of the machine), and the live CD seems to recognise it as the same card as it's showing in Vista. –  BT643 Aug 3 '12 at 20:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.