Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This is the single most infuriating issue I have with Windows ever since XP. I recently built a new system and bought Windows 7 32bit.

I am an electrical engineering student and I have a whole host of development kits and trinkets that connect via USB and the virtual com port drivers. Some use the FTDI chips for the interface and other use a Pic or AVR chip for it but either way their is an issue with Windows 7 and the CDC driver process.

I have a PIC running as a serial bridge. The device works perfectly fine on my XP machine so I know their is no hardware concerns. Below is the INF that will install on XP without any issues at all. mchpcdc.inf

Windows XP has usbser.sys in its drivers folder at OS install so the stock INF works for that system. On Windows 7 its in the driver catch and you must use the commented changes to make it found. This is the way the internet recommends and this works on a Vista computer at school.

This might work on Windows 7 except my device shows up in the hardware manager as an "Unknowen Device" under "USB Controllers" and when I manually point it to the INF above it simply says "Does not contain a software driver for your device" and setupapi.dev.log does not even output anything other than that same message!

I tried "Add Legacy Hardware" and that loads the driver exactly as it should but the driver is not actually pointing to any hardware. When I unplug the Pic the legacy device stays listed and when you open it in TeraTerm it can not connect to that com port.

Does anybody know how to force feed Windows 7 these drivers as I have about 5 devices I use on a weekly basis that do exactly the same thing!!!

share|improve this question

1 Answer 1

Have you considered using virtual machines for your legacy hardware? I know that VirtualBox supports serial ports and USB. I've tried USB devices and they worked great! Basically you install Windows XP into a virtual machine and configure the devices through the VM interface.

Might not be the ideal answer that you wanted but it can be a good solution nonetheless.

share|improve this answer
    
The problem with a VM on Windows is its communicates with the peripherals through the host. I tried this to get my AVR Dragon (Another device not working on Win7) but if its not installed properly on the host then VM can not see it either. –  uMinded Aug 4 '12 at 0:56
    
Hmm really? I thought that a USB device on VBox passed right through the host to the VM. Which VM software did you try it on? VMWare, VBox, etc. –  Canha Aug 4 '12 at 1:20
2  
I just went to research the VirtualBox capabilities and I quote: "VirtualBox can allow virtual machines to access the USB devices on your host directly. To achieve this, VirtualBox presents the guest operating system with a virtual USB controller. As soon as the guest system starts using a USB device, it will appear as unavailable on the host." –  Canha Aug 4 '12 at 1:28
    
+1: I have a scanner with no x64 drivers to use on Win 7x64. Fire up XP Mode (x86) and install the old drivers. Attach scanner and scan like it is 1999. . . Ba Bada Ba BA ba. –  surfasb Aug 5 '12 at 2:31
    
@Canha I have been trying dozens of times and its not working. The USB device in Windows device manager has no VID/PID except under the "Siblings" ID. I have put the VID/PID that the device is suppose to have in as well and my guest (ubuntu) can not see it under lsusb. –  uMinded Aug 6 '12 at 19:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.