Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have several standalone applications in my "My Documents" folder such as "procexp.exe", "putty.exe", etc.

I noticed that Windows Search does not index them even though "exe" is a file type that should be indexed (file properties filter) according to the advanced options of Windows Search.

The "exe" files show up when I consult the full "Search results" after entering my query and clicking "See more results" in the Start menu.

How can I make them show up in the start menu search result listing? What can I do to solve my problem?

share|improve this question
1  
I'm looking for the exact same thing - I have SysInternals tools in a folder and I don't want to create a shortcut for every single one, nor put them on the path. The index is clearly working right because doing a search in Explorer finds them. But they just don't show up in the Start Menu search. This used to work in the RC, so is this perhaps an issue with Windows 7 RTM? – scobi Dec 21 '09 at 0:24
up vote 1 down vote accepted

It should do and whilst I have other problems with indexing on my machine, it does return .exe results.

Try going in to options and rebuilding your database.

share|improve this answer

If you'll consider using a better search engine, the Everything search engine might be suitable.
The only requirement is that your disk must be formatted in ntfs. It's quite nice to have your answers display in real time per each character while you're still typing the file name.

share|improve this answer

Perhaps what you really want is to add My Documents to PATH in your system environmental variable. This allows you to just do a Windows+R and type in procexp or putty to run those programs.

I like that you can find programs using Windows Search, but if you already know the name of the program, it is faster to just run it from the Run prompt.

This is for Windows 7:

  • Control Panel > System
  • Advanced system settings
  • Go to Advanced tab and select Environment Variables
  • In System variables, scroll down to path
  • Click Edit
  • Add your My Documents path, such as c:\users\me\documents
  • Make sure to use a semicolon separator
  • Click OK

enter image description here

share|improve this answer

I had a similar problem, but I discovered that I could not search for anything in folders like "My Documents", "My Music", etc. I found this solution on sevenforums after much searching: http://www.sevenforums.com/general-discussion/265005-win-7-x64-start-menu-search-not-searching-documents.html

Quote: Originally Posted by MikeOrlando02

One thing that I did notice is that on the start menu search the files are do see at under Files. I think I found a work around solution based on a MS Hotfix.

There is a way to get Windows to search non-indexed files on the start menu search. I don't understand why this is necessary as my documents are indexed; however it did work.

In HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\SearchPlatform\Preferences

Create a 32-bit D-word EnableSearchingSlowLibrariesInStartMenu and set that equal to 1.

Then restart the Windows Search Service or Windows and now when I search in the start menu search I see my document files under a Documents heading and not Files.

Not sure why the files that I have indexed and re-indexed are not showing on the start search, but this appears to work for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.