Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'd really like to stop reading Arial online, when I have the lovely Helvetica installed. Unfortunately, many sites specify their font familys as "Arial", "Helvetica", sans-serif, which means that I get Arial rather than Helvetica.

I had the idea to disable Arial and all it's cousins in Font Book, assuming this would work. Weirdly, this changes the font, but it still looks like Arial, albeit a different weight. These two images show the situation. (I've disabled Trebuchet MS to get this site to show the problem)

Interestingly, the Question title is in Helvetica, but not the Nav bar or the other sections.

Normal

alt text

Arial, Arial Black et al. disabled

alt text

As you can see, even with Arial disabled, it's still using a varient of it. Looking at the capital R in Rich is a quick test. This looks horrible on screen.

I've tried actually deleting the Arial fonts from /Library/Fonts, but this doesn't seem to make a difference.

Non Cocoa apps like Firefox don't have the same problem and respect the fact that Arial doesn't exist/is disabled.

How do I stop Arial appearing?

(EDIT, about a day later: Ah, seems that randomly it's started ignoring Arial when disabled. Didn't restart, it just decided to play nice...)

share|improve this question
    
Dude. If this is what you're worried about, you have too much time on your hands. –  Beska Sep 23 '09 at 17:24
    
I know. I do sometimes wonder about my sanity... I'm more interested in how the fonts are handled - where is it getting Arial from? Why doesn't the font stack work as expected. –  Rich Bradshaw Sep 23 '09 at 17:26
1  
I'm totally with you, Rick. Why use a cheap knockoff of Helvetica when you can have the real deal? –  mipadi Sep 23 '09 at 17:47
1  
Exactly. Arial is pretty unreadable on screen, nothing is straight, it's all angled and horrible! –  Rich Bradshaw Sep 23 '09 at 17:50
2  
I wonder why Arial is specified first anyway -- seems like Helvetica should be first, since just about everyone has Arial so Helvetica will almost always be masked. –  mipadi Sep 23 '09 at 18:05

2 Answers 2

up vote 4 down vote accepted

In Activity Monitor, use Get Info on the browser you are using, and look at the open files:

enter image description here

That will show you where the font is being taken from. I suspect that the new technologies in Leopard/Snow Leopard to activate fonts on demand are what are causing Arial to come back, and without forcibly erasing all existance of it, I'm not sure what you can do. You could use an applescript to move arial out of the font library, then start your browser, and another applescript to close your browser then move arial back.

Do note however that Browsers like Opera and Firefox can apply custom user styles (per-site built-in to opera), so you can easily override arial on sites you choose. I often restyle sites to use fonts I choose - very powerful and useful for typography nerds like us.

Also if you want a brutal shotgun approach, use a bookmarklet (copy as an address and make a bookmark out of it, clicking it will test it on this page):

javascript:void(document.body.style.fontFamily='helvetica!important')

And back to Arial:

javascript:void(document.body.style.fontFamily='arial!important')

This bookmarklet is even more brutal, will change everything on a page to helvetica

javascript:for(i=0;i<document.getElementsByTagName('*').length;i++){document.getElementsByTagName('*')[i].style.fontFamily='georgia'};return;

And, as you may find something useful, the most comprehensive and useful guide on font management for OS X:

http://www.jklstudios.com/misc/osxfonts.html

share|improve this answer
    
Safari allows the use of user style sheets as well. You can find this in Safari Preferences > Advanced. You can't make per site style sheets, which is somewhat unfortunate. I currently use mine to keep my wife from signing me out of Facebook in Safari by hiding the sign out button. –  Pinochle Sep 25 '09 at 8:34

If your using Firefox, you can go to Options->Content and click the Advanced button next to the font settings. From there, select Helvetica and the size you want, and de-select the checkbox saying "Allow pages to choose their own fonts instead of my selections above". From now on all pages will use Helvetica.

share|improve this answer
    
Interestingly I don't have the same problem in Fx - seems that it doesn't magically get Arial out of thin air to destroy the typeography... –  Rich Bradshaw Sep 23 '09 at 17:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.