Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Run command box link in the Start menu. Today when I booted my PC, that run command was missing.

I tried running commands such as %system root%, msconfig.msc in Start menu, but no results. I have searched Start menu properties for a Run menu – nothing found. I opened Task Manager to find New task to get a Run window, but it wasn't focused when I pressed WinR. A message box returned:

This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator.

What can I do?

share|improve this question
add comment

3 Answers

up vote 3 down vote accepted

The easiest way to undo a very recent change is almost always restoring the system to a previous state.

If that's not an option (e.g., if there's no recent restore point), you should be able to undo these changes manually, as detailed below.

I have a Run command box link in the Start menu. Today when I booted my PC, that run command was missing.

To undo this change, right-click the Start button, go to Properies → Start Menu → Customize... and make sure the option Run command is checked. Then, click OK twice.

A message box returned:

This operation has been cancelled due to restrictions in effect on this computer. Please contact your system administrator.

The NoRun value in the Software\Microsoft\Windows\CurrentVersion\Policies\Explorer keys of the HKEY_LOCAL_MACHINE and HKEY_CURRENT_USER hives determine whether you can or cannot access the Run dialog:

  • If NoRun is set to 1 in HKEY_LOCAL_MACHINE, you cannot.
  • If NoRun is set to 0 in HKEY_LOCAL_MACHINE, you can.
  • If NoRun is missing in HKEY_LOCAL_MACHINE, the corresponding setting in HKEY_CURRENT_USER decides. The latter has no effect if the first is present.

To remove the restriction from any user account, do the following:

  1. Log into an Administrator account.

  2. Press Win + E to open Windows Explorer.

  3. Open the System32 folder (usually C:\Windows\System32).

  4. Search for cmd.exe, right-click it and click Run as administrator.

  5. Execute the following command:

    reg add HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer /v NoRun /t REG_DWORD /d 0 /f
    
  6. Then,

    • to remove the restriction only from the current user account, execute the following command:

      reg add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer /v NoRun /t REG_DWORD /d 0 /f
      
    • to remove the restriction from a different user account, find out its SID by executing the following command:

      wmic useraccount get name,sid
      

      Afterwards, execute

      reg add HKU\<SID>\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer /v NoRun /t REG_DWORD /d 0 /f
      

      where <SID> is the user account's SID.

    • to remove the restriction from all existing users accounts, execute the following commands:

      for /f "tokens=1,2" %a in ('wmic useraccount get name^,sid') do @if not %a==Name if not "%b"=="" reg add HKU\%b\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer /v NoRun /t REG_DWORD /d 0 /f 2>nul
      
  7. Reboot your computer to make the changes take effect.

If you can't perform any of the steps, try disabling UAC or booting in safe mode. If the problem persists after following these steps, execute

reg query HKLM\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer /v NoRun
reg query HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer /v NoRun

to check if the registry values are still set to 0.

If they aren't, I recommend reading Computer is infected by a virus or a malware, what do I do now?.

share|improve this answer
2  
The reg add command supports the /f flag, which eliminates the need to pipe "yes" into it. –  Harry Johnston Aug 5 '12 at 1:45
    
error pops up access denied –  Go K Ul Aug 5 '12 at 12:04
    
@GoKUl: Are you logged in as Administrator? Try disabling UAC or booting in safe mode. Since the problem started recently, you could also try system restore. –  Dennis Aug 5 '12 at 14:30
    
no use on first two suggestion and I am an administrator-I have tried to create a new admin user-but same problem in both users –  Go K Ul Aug 6 '12 at 11:42
    
anyway without any other way system restore worked –  Go K Ul Aug 6 '12 at 12:56
show 1 more comment
  • Go to the control panel, aet the display to "small icons" and select "Taskbar and Start Menu Properties".

  • On the "Start Menu" tab, left-click the "Customize" radio button.

  • In the "Customize Start Menu" dialog box, scroll down to "Rin Command" and check the box.

  • Left-click the "OK" button in the "Customize Start Menu" dialog box.

  • Left-click the "Apply" button in tke "Taskbar and Start Menu Properties" dialog, then "OK".

  • You should then find the Run Command at the bottom of the right pane when you click the "Start" button.

share|improve this answer
add comment

If you are the system administrator, enter group policy editor, and navigate to User Configuration > Administrative Templates > Start Menu and Taskbar. Right click on "Remove Run from Start Menu" and click edit. Select either "Not Configured" or "Disabled".

enter image description here

If you are not the system administrator, ask your administrator to do the steps above.

share|improve this answer
    
not worked it was already not configured –  Go K Ul Aug 4 '12 at 15:47
    
oh. Sorry i don't know of any other way :( –  wolfo9999 Aug 4 '12 at 15:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.