Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So, I have bind on zeroshell, I can make a DNS zone for lets say "http", I can then set a DNS A record on 'test' for example and have "test.http" point to an IP address

But then I have an issue if I simply want to have a record on "http", it will only resolve if I try and resolve it with a trailing dot, for example:

http - will not resolve
http. - will resolve

Is there anyway I can get around this so that I do not have to add a trailing dot, so it will resolve just as "http" for example?

I have tried searching and found nothing. I have also noticed that I can make DNS zones which have a dot in them, for example "test.com", resolve at the highest level.

One theory was it's trying to resolve these names not via DNS but the local directory of hosts on the network? if so is it possible to over-ride /disable this on Windows?

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.