Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have vim without any special configuration and use it to edit my latex files. The following strange thing happens.

I have the following text types:

1234 people live in Hobit Land, Further Text, Further Text, Further Text

If I now type further until the line break occurs and type further, the following line is idented:

1234 people live in Hobit Land, Further Text, Further Text, Further Text
     and contiunes the line and further on....

Why is this the case? Its anoying because very time a line starts with a number (maybe even within text, only due to a linebreak before), the next text gets indented without sense.

How can I turn this of?

share|improve this question
1  
What configuration do you use? When I start vim with ´-u NONE` and set the textwidth to some value I do not observe the behaviour you're describing. –  Marco Aug 4 '12 at 16:08
    
Yeah, you were right, I got a strange formatoption, just as the answer below correctly states. –  theomega Aug 4 '12 at 17:46

1 Answer 1

up vote 2 down vote accepted

Your current formatting settings are configured to recognize numbered lists, which are basically just lines starting with a number.

Remove n from 'formatoptions'. It's not a default setting, so you probably just need to modify :set formatoptions=... in your .vimrc file to remove n.

See :help 'formatoptions' and :help fo-table for details.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.