Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

New Laptop HP8760W I have installed Firefox latest beta version. When I am trying to start the Firefox I see under processes it is running but window is not popping up.

I tried all possible ways of running CCleaner cleaning registry – no use, tried uninstalling, reinstalling, restarting, nothing worked.

share|improve this question
    
Have you tried running a non-beta version? – Oliver Salzburg Aug 4 '12 at 18:31
    
Are you on the administrator account? – ahmed Aug 4 '12 at 18:38
    
tried non-beta version and I am running on administrator account. – changeme Aug 5 '12 at 0:12

First of all: any registry cleaner help fixing this problem as well as many others... The best effect of registry cleaners is a placebo effect to say the less...

What you can try is to follow the troubleshooting procedure from Mozilla:

Troubleshoot and diagnose Firefox problems - support Mozilla.org

Please note this problem may be related to Windows conditions and not a Firefox problem such as bad sectors, malwares or even some security software parameters...

share|improve this answer
    
tried ... none worked. – changeme Aug 5 '12 at 0:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .