Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Windows 7 and Windows XP guests on Virtualbox 4.1.20 r80170 on 64-bit Ubuntu 12.04 host, and when in the Windows guest, a horizontal mouse wheel-scroll becomes the alt-vertical-scroll event (with effect similar to page-up/down). This is very annoying as whenever I accidentally touch horizontal scroll wheel the whole page jumps up or down a full page or more. This happens both of my mouses. I have the latest guest addition installed on the guest Windows 7 and XP OSs. I've tried both PS2 mode and absolute position mode (e.g. tablet mode) HID mouse emulation in virtualbox setup, with same result. I can't find any mention of this problem after an hour of search.

BTW, the same Virtualbox with an Ubuntu guest works fine, e.g. horizontal and vertical mouse wheel-scroll work as they normally should.

If it can't be fixed, e.g. horizontal scroll-wheel to scroll horizontally, then I don't mind if there is a way to disable horizontal scroll-wheel events from Virtualbox's .vbox guest-machine configuration. Or, if there are software in Windows (in guest) that can intercept and remove alt-vertical-scroll events or event-handling (e.g. in regedit) would be great too.

share|improve this question

I've had a similar but not identical issue with Windows 7 host and Linux Mint guest. My solution so far is to disable then re-enable the mouse, and the scroll-wheel behavior returns to the original default.

share|improve this answer
1  
Hope the solution can be more reliable than this, but it is a start. – vgoff Nov 7 '12 at 0:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .