Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This has been occurring on all Windows 7 machines I own, and I would like to finally know a reason why it is happening.

Icon showing no network access

Icon showing no network access

The icon is showing that the computer is not connected to a network, but it actually is and it shows this on mouse-over or if you click it and get the dialog above.

This hasn't happened in Windows Vista, so I wonder what it is in 7 that made this happen.


EDIT: I though perhaps it might be multiple adapters on my computer causing the problem, but I realised that I had them all disabled. Could this possibly still be the problem, as I really wouldn't like to uninstall VirtualBox and TeamViewer.

All network adapters disabled except one being used

share|improve this question
    
I had this. It was a virtual network adapter for VMware if I remember correctly. –  Nifle Aug 5 '12 at 7:08

3 Answers 3

up vote 1 down vote accepted

This can depend on a few factors , but i'm going to guess your router( or other network link device) is doing somthing that confuses Windows 7 when it checks to see if its connected to a network .

But if its not causing a real problem, then i'd leave it alone( if you really need to push this try updating the router frimware)

share|improve this answer
    
Well my router's firmware has just been recently updated, so that probably won't solved it. Could you please explain to me why the icon would be showing something different to the actual status if you click on it? –  njallam Aug 5 '12 at 5:30
    
At that point its just a strange Windows 7 UI bug, I wouldn't worry about it since the fix would just complicate things . –  Keithsoulasa Aug 5 '12 at 5:33
    
OK, that's what I thought. I was just wondering if there was anything I could do to fix it. –  njallam Aug 5 '12 at 5:38

If you are going through anything that is proxying HTTP/HTTPS and captures all that traffic, then BITS/WinHTTP must be notified how to access the network through the proxy. The connection indicator basically is a detector to tell you if sufficient internet access is available for Windows Update to function. Its secondary use is to tell you if you have an internet connection.

Antivirus/Antimalware programs can attempt to intercept all HTTP/HTTPS traffic and firewall off the system from accessing these transport protocols directly. Things will seemingly work, except the indicator says you aren't connected and Windows Update fails to connect and retrieve updates. Firewall/Routers can set specific rules that block direct access through port 80/443 and proxy the traffic creating the same situation.

First step in seeing if this is the case is to run Windows Update, try to do a manual update and see if it errors out.

share|improve this answer
    
Windows Update can run fine and the problem still occurs. –  njallam Aug 5 '12 at 7:07
    
Ok, then you have another issue. I've been dealing with my version of the failure on Windows 7 due to a proxied company network and had to make the indicator and Windows Update come back to life. Browsers, etc worked fine because they were all using the proxy settings out of Control Panel, not so with WU and that indicator. –  Fiasco Labs Aug 5 '12 at 7:27
    
I am using a custom DNS server (OpenDNS). Could that affect it? –  njallam Aug 5 '12 at 7:28
    
DNS is port 53 traffic and I think the indicator is only looking for port 80/443 traffic. Once I'd told WinHTTP that all 80/443 traffic had to go out a proxy on port 3128, the indicator told me the internet connection was solid. –  Fiasco Labs Aug 5 '12 at 7:32

I dont know if you solved it but i had the same exact problem. They problem here is that your ISP may not support IPV6 and so windows will show no network because IPV6 has no acces to network. The solution is to disable COMPLETELY ipv6 for this network card Just go at network and sharing center and at your conection details it should say connections:blabla bla (for me it is Local Area connectioin 2. Click that, then properties (it will need administrator rights) and untick Internet protocol version 6 (tcp/IPv6) Done!!!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.