Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a had name server set up for my websites on my server but a while back the I put a new network in and it stopped the name server from working. I didn't have a back up name server off site so I just used cheapname.com for my dns server. This worked well until I removed the new network card because it didn't help me and was causing more problems. I put all the settings back to what they were before with the old network card and now the websites are down.

I have checked on http://www.whatsmydns.net and it shows that the web-sties are not propagated. The only thing I can think of is that the two name servers are not getting along. I am really new to dns so I just need to know if this could be the problem and what needs to be changed. namecheap.com doesn't support zone transfer so I have went through and matched the records on my server and theirs manually. the only thing that I haven't matched is a line in the bind config files for the websites that is ns3 then my ip.

I am running a Ubuntu server with bind and apache.

share|improve this question
    
Can you put your bind files to a site like pastebin.com and tell the url? –  ott-- Aug 5 '12 at 18:43
    
this is basically the same on all of the sites –  monkthemighty Aug 5 '12 at 23:07
    
I can now check whatsmydns.net and it will bring up the ip and the mx record but i am not receiving email still and the websites and some of the websites are not working. not all of the dns servers in the us have the ip but all of them have the mx records –  monkthemighty Aug 6 '12 at 2:07
    
You can try a DNS checker tool such as intodns.com, might be able to help. I run a network of three free shell servers (nipl.net) including a nice DNS management system I wrote called freens. Freens makes it easy to generate correct bind9 config files, so it's easy for me to host various domains. I would be happy to host your DNS for you free of charge, and also to give you an ssh / web / mail account if that is of any use. Freens does not have a web interface yet, but I could develop one so that you can update your zone files without using the command-line. –  Sam Watkins Aug 6 '12 at 7:12
    
What is the TTL for the NS records? It may just need to propagate. –  user3463 Aug 6 '12 at 7:28
show 1 more comment

1 Answer

What i did to fix this is to add the name server to the bind config file for each website and made sure that both the records on the server and on namecheap were the same then waited and everything went fine. The waiting is the hardest part. everything looked fine on whatsmydns.net but it still didn't work but by morning it worked just like it should

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.