Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using VMware Fusion 2.0 on a Macbook Pro. I have allocated 20GB to a windows partition within VMware, and now wish to expand that. When I go to the settings for the hard drive it tells me: "These settings cannot be changed while the virtual machine has a snapshot. To make changes, first delete all snapshots." When I go to the snapshots settings nothing appears there besides the current state thumbnail. Is there a way to remove these "invicible" snapshots??

share|improve this question
Is this VM Suspended or Off? – Nicolas Webb Sep 23 '09 at 19:13

Have you got auto-protect on?

In the window showing snapshots there is a check box at bottom left that toggles showing the protection snapshots

share|improve this answer

I had this problem while I was trying to expand my virtual machine as well. The virtual machine was fully powered down and there were no visible snapshots, but it still said I had one.

My solution was to make a new snapshot and delete it. Hopefully this will fix your problem as well.

share|improve this answer
I had exactly the same problem and your solution worked very well for me. Thanks! – ShreevatsaR Feb 1 '11 at 9:53

One way to do it is to use VMWare Converter to convert this VM to a new VM. All snapshots will be deleted as part of the process.

share|improve this answer

If you navigate using the terminal to the directory containing your VM:

$ ls -lha

you should see some "name-SnapshotX" (where X denotes how many times you've taken a snapshot) files.

You CAN delete these, but not recommended.

As far as resizing your HDD. VMware Converter (Windows only) is the best way of doing this due to the automated partition adjustment. As if you do it manually (by adding more through Fusion HDD dialog), you'll just have a large drive, with a lot of empty space, which your Windows will not recognise, and then you'll have to muck around with partition resizing internally.

Hope that helps.


share|improve this answer

I had a an issue with a VM where I wanted to change the disk mode, however I had already taken a snapshot of it.

it sort of gave me the same error message as yours when I tried to delete it.

I finally got rid of the snapshot by creating another snapshot and deleting them all.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .