Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just bought a new router and installed DD-WRT on it. When I connect to the router via wi-fi, I cannot get an outside internet connection (and in fact, can not connect to the router admin interface at 192.168.1.1). If I connect to it with an ethernet cable, I can get an outside connection just fine. At first that wasn't the case, but I cloned the MAC address of my old router as suggested here, and now get an outside connection.

I've tried to duplicate the settings from my old router as best I can (it was also running DD-WRT), but to no avail. What steps can I take to troubleshoot and solve this problem?

share|improve this question
    
To whomever downvoted this question: could you please explain why? Thanks! –  tnorthcutt Aug 6 '12 at 13:56
1  
Hit-and-run down-voters rarely bother. :-( (Have you argued with anyone recently? Sometimes you get hit with revenge down-voting.) –  Synetech Aug 9 '12 at 1:34
    
Have you tried it with all wireless security disabled ? –  harrymc Aug 10 '12 at 8:18
1  
What IP address do you receive when connecting wirelessly? –  Tanner Aug 11 '12 at 2:28
    
Can you specify what's the brand and model of your router? –  Zuul Aug 11 '12 at 11:14

3 Answers 3

  1. Check you have received the IP from the DHCP pool.
  2. Ensure the wireless NIC MAC is not blocked in the router for any reason.
  3. Login to the admin interface (in wired) and verify the WLAN settings.
  4. Make sure the authenticate / encryption are selected appropriate.
share|improve this answer
    
How do I check that I have received the IP from the DHCP pool. How do I check that the wireless NIC MAC is not blocked in the router? –  tnorthcutt Aug 5 '12 at 23:47
    
1) To check the IP in command window => ipconfig (MS) or ifconfig (linux) 2) You need to login to the router using ur wired interface and check the WLAN settings. There might be something stopping ur connectivity. –  manick Aug 5 '12 at 23:51
    
What should I be looking for when I run ifconfig? I'm sure there is something blocking my wireless connectivity, but I can't figure out what, which is why I asked the question here. –  tnorthcutt Aug 6 '12 at 0:47
1  
you'll be looking to see what IP address the command returns for your wireless interface. –  VBwhatnow Aug 9 '12 at 8:45
    
Did you ever find out what address it was assigning you when you connected wirelessly (ifconfig)? –  user142485 Aug 14 '12 at 13:11
  • Start
  • Accessories
  • Scroll to the "Command Prompt"
  • Right-click on "Command Prompt", Choose "Run as Administrator"
  • Run this command: netsh winsock reset

You'll be prompted to reboot.

share|improve this answer
    
I'm on a Mac, but that's beside the point - I've tried to connect with this machine as well as a windows machine, and neither is able to get an outside connection when connected to this router via wi-fi. –  tnorthcutt Aug 8 '12 at 20:03

You're in luck :) I have DD-WRT on my router. I'll give you some options to change and see if it fixes things.

1: Go to Wireless > Basic Settings , and check the Advanced Settings box. Try enabling AP Isolation or setting Network Mode to Unabridged.

2: Make sure your wireless card is compatible with 802.11 B,G, or N.

3: Go to Administration > Management , and make sure 802.1x is turned on.

If possible, tell me the IP you get when joining wirelessly, and joining via ethernet. To get that on a mac, enter ifconfig in Terminal, and look for IPv4 address.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.