Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I've been trying anything and everything under the sun to fix this problem.

Have a lenovo Y570 laptop and decided to duel boot linux mint alongside windows 7.

I partitioned some space on the windows side after the install. I then rebooted and came to this grub rescue screen. I've read about all the ways to fix it and applied all of them basically burning, typing, etc every type of media including windows 7 dvd's, linux mint boots of usb and dvds.

The problem is my computer BIOS menu is completely gone. Everytime i try to boot the computer to the cd drive, usb, etc. I hear it spin up and it still takes me to the screen of grub rescue.

I have all types of windows boot software burned to different dvds and usb sticks, but my computer will not boot to any of these. I've spent over 5 hours searching, burning, applying all types of fixes and I still get sent to the grub rescue screen.

If there is an alternative to way to get something to boot up, please, I need advice.

Thanks in advanced.

EDIT: Mashing any/and/or all buttons like F12, F2, esc, delete, etc does nothing within the BIOS.

share|improve this question
add comment

1 Answer

You presumably have the BIOS set to "quick boot", which skips the POST and possibly doesn't show information on keys to press to get to the BIOS menus.

According to the Lenovo manual (page 39, marked "35"), you can get the boot menu by mashing F12 when it powers on. From there, you should be able to select a device to boot off of.

share|improve this answer
1  
I've read into it as well. Problem is there is no longer an option to boot from anything. Pressing any key including f12, etc still doesn't effect the turnout. I feel like I might have to pull the drive and access it with another computer. –  hijaked79 Aug 6 '12 at 3:48
    
So i've read into it a bit more. It looks like I do have to pull the HDD and run it in an external case from another computer in order to access any data on the drive. –  hijaked79 Aug 6 '12 at 6:28
    
But it doesn't seem like your BIOS is dead, since it does boot, so why isn't the boot menu working? –  Mechanical snail Aug 6 '12 at 6:29
    
So I fixed the problem, but it to do it, I had to pull the drive out, connect it to my other PC, and run MBR Repair from MBR Wizard. Threw the drive back in and it fired right back up. If anyone is having the same problem, and get any media to boot whatsoever, pull the HDD and fix the MBR with another computer. That's all you got to do. –  hijaked79 Aug 8 '12 at 16:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.