Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I just replaced my old DLINK router with a Cisco RV180 (and a new zyxel nwa3560-n as AP). I have forwarded ports 80 and 22(ssh) to my servers local ip.

When I use my phone over 3G network, it is no problem to connect to either server over http and ssh on the external IP. But when I try to connect to the server over wifi using the external IP, as I always did when the DLINK was the router, I get the router settings page.

This is not desired behaviour, as some employees use a website which then points to our external IP (the http service). They need to be able to do this both from this site and from other places.

How can I configure the router so it will not forward to the router settings page when the external IP is used from the inside?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

You probably can't. You will need to set up the internal DNS servers to override the A record for the appropriate hostnames.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.