Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

The title says it.

When I try to export a png I get the following dialog, where I can choose the PPI, but not the resolution.

enter image description here

Playing with the PPI around to get the right size could probably work, but it's annoying. There must be a better way, since resolution independence is the entire point of vector graphics.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I have an older version of AI running on Windows, but with it the way I do what you want is by selecting Save for Web... on the File menu which opens a dialog of the same name. In that over on the right you can select the PNG output format desired, and then on the Image Size tab you can set the exact horizontal and vertical resolution of the image created.

This can still be a little tricky because when either using Export... or Save for Web..., the overall image dimensions/aspect ratio are determined by an imaginary bounding-box that encloses all the objects in the drawing. Because of this, it is sometimes necessary to add an empty rectangle around the (larger) area desired to force the proportions to be what is desired. Alternatively you can sometimes do this afterwards in Photoshop (or other image-editor).

Here's an illustration of using Save for Web... to create a 24-bit PNG file showing where to set the pixel resolution in the dialog:

screenshot of the save for web dialog showing where to set the image size

share|improve this answer
    
I can't believe I missed that little tab! Thanks, works perfectly on the OS X version as well. –  houbysoft Aug 6 '12 at 16:37
    
@houbysoft: That's good to hear. One nice thing about Adobe's desktop programs is that they usually run almost identically on all platforms, so I thought the answer might help. –  martineau Aug 6 '12 at 16:50

There is no need to bring the image into Photoshop afterwards.

Just tick the checkbox that says "Clip to artboard".

This will clip bleed and any objects such as shapes etc that extend past the artboard.

share|improve this answer
1  
This is not an answer to the original question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  DavidPostill Nov 4 at 8:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.