Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Salvete! I want to add the Powershell Console for Sharepoint to the tablist in Console2.

I already have plain Powershell, but I want the Sharepoint Powershell snapin added automatically.

If I look at the properties of the Sharepoint Powershell Console shortcut, I see this:

C:\Windows\System32\WindowsPowerShell\v1.0\PowerShell.exe -NoExit  " & ' C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\POWERSHELL\Registration\\sharepoint.ps1 ' "

but that doesn't work in Console2, so I tried this, which doesn't work either:

C:\WINDOWS\system32\windowspowershell\v1.0\powershell.exe -PSConsoleFile "C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\POWERSHELL\Registration\psconsole.psc1"  -NoExit  " & ' C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\POWERSHELL\Registration\\sharepoint.ps1 ' "

Whenever I try, it will load Powershell, but not the Sharepoint Console. I get this:

Add-PSSnapin : The Windows PowerShell snap-in 'Microsoft.SharePoint.PowerShell' is not installed on this machine.
At C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\14\CONFIG\POWERSHELL\Registration\SharePoint.ps1:3 char:13
+ Add-PsSnapin <<<<  Microsoft.SharePoint.PowerShell
+ CategoryInfo          : InvalidArgument: (Microsoft.SharePoint.PowerShell:String) [Add-PSSnapin], PSArgumentException
+ FullyQualifiedErrorId : AddPSSnapInRead,Microsoft.PowerShell.Commands.AddPSSnapinCommand

I tried this out, too.

Anybody know?

[update]

I read that it IS possible to load the 64bit Powershell by inserting

%SystemRoot%\syswow64\WindowsPowerShell\v1.0\powershell.exe

into the Shell field in Console2's settings. However, if I tack on the ending, -NoExit add-pssnapin microsoft.sharepoint.powershell, I still get the error for the sharepoint snapin. However, System Explorer says that is a 32 bit application!

The 64bit powershell is here, believe it or not:

C:\Windows\System32\WindowsPowerShell\v1.0

share|improve this question
2  
Give a try to ConEmu: stackoverflow.com/a/10904494/1405560 – Maximus Aug 6 '12 at 20:40
    
Nice app. I'll look into that. – bgmCoder Aug 6 '12 at 21:17
    
I guess nobody knows how to do it with Console2! – bgmCoder Aug 8 '12 at 18:15
up vote 4 down vote accepted

Make sure that you are using the 64-bit version of Console2. The 32-bit version will start the 32-bit version of PowerShell, and as previously reported, the 32-bit versi

share|improve this answer
    
Ah! Good point! Sharepoint demands 64bit in the first place. I think that is the clencher. I was using the 32bit version. – bgmCoder Dec 18 '12 at 21:40
    
Any idea where to get a 64 bit version? I don't find it on Sourceforge. – bgmCoder Dec 18 '12 at 21:45
    
However, I CAN load the 64bit Powershell by setting the Shell path to: %SystemRoot%\syswow64\WindowsPowerShell\v1.0\powershell.exe. But it doesn't help with the Sharepoint snapin. – bgmCoder Dec 18 '12 at 22:00
    
Here is the link to the 64bit version of Console2: sourceforge.net/projects/console/files/console-devel/2.00 – bgmCoder Dec 20 '12 at 22:53
    
Okay, got 64bit Console2. I still have the same problem. – bgmCoder Dec 20 '12 at 23:26

Try putting the command in a batch file; it may be a command line interpretation problem within Console2 because of the quotes and ampersand.

Get it working by double clicking on the batch file in Windows Explorer; then, provide the path of the batch file in Console2.

share|improve this answer
    
Same thing. I posted the error I receive. It is the same error whether I use the (working) batch file, or the entry in Console2. – bgmCoder Aug 6 '12 at 15:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .