Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to print in Google Chrome it says "Loading Preview" and just hangs there. Up to this week it has been printing fine. What can a technophobe like me do?

share|improve this question
    
Delete your Chrome profile. –  Ramhound Aug 6 '12 at 16:05

2 Answers 2

Chrome updated last week. There are numerous reports of such behavior. From the Google Chrome forum dated Aug 3rd...

The team has identified the issue and is working on a fix. In the meantime, you can try these solutions:

  1. Installing either the XPS Essentials Pack, NET 3.0 or NET 3.5 should resolve the issue (note: make sure to restart Chrome after installing)
  2. Use "Save as PDF" or Google Cloud Print printers
  3. Use the local system dialogue-- either by clicking the system link in print preview or using the shortcut Ctrl + Shift + P on Windows
share|improve this answer

If someone else is getting this, what helped me was quite simple.

I've setup Google cloud printing today, and had the "Loading preview" issue as well.

It turns out that a simple restart to both chromes (on the printer-connected computer, and the client computer).

Make sure you really restart chrome and not just the visible window (you can make sure by restarting the computer).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.