Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've setup squeeze on a separate partition on my existing win-7 system. However, I'm facing two issues:

[1] The ntfs drive isn't mounted automatically when the computer starts. I have to manually mount it by giving the root-password. I've added the below lines to /etc/fstab but its not working:

#Added by Prahlad
/dev/sda3   /media/SHARED   ntfs    user,auto    0    0

Is there anything wrong in this entry? user,auto option should auto-mount on startup right? I also verified /dev/sda3 is correct by running "fdisk -l".

[2] The grub boot-loader displays the secod OS as "Windows Vista (Loader)". I want to change this to "Windows-7" and also make it default. How to make that. Should I edit the /boot/grub/grub.cfg directly?

Thanks in Advance.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

[1] - fstab

Only obvious thing I can see wrong is that you're using ntfs rather than ntfs-3g. The latter is a user-space filesystem (which has been around for many years and is VERY stable) which can read and write NTFS reliably. The ntfs filesystem driver is a kernel module in the Linux kernel that is much less mature and (AFAIK) does not provide write support, nor can it handle volumes that have a dirty journal (again, AFAIK).

When you have issues like this, the best way to debug it is to try and mount it manually. As root (or add sudo in front of it):

mount /media/SHARED

If you get an error post it here. If not..... hmm.

The other problem that may exist is that the device may not be stable. Sometimes the BIOS boot order and plugging in / unplugging devices (SATA disks, USB disks, etc) can cause the block devices to have different names. One boot it may be /dev/sda, the next boot it may be /dev/sdd. You can get the UUID of the specific partition and use that in /etc/fstab instead of the /dev/sda3 device node identifier. A fairly good write-up on how to determine UUIDs and use them in fstab is at the Ubuntu wiki, but note that some commands they advise you to run may not work with Debian. Instead, just follow the instructions under "Finding UUIDs" and manually plug the UUID into /etc/fstab by using the syntax UUID=BlahBlahIAmAUUID instead of /dev/sda3.

[2] - Grub entry name

/boot/grub/grub.cfg is for GRUB2. If the file exists, you can go ahead and edit it and replace the name appropriately. You can also see if a setting in /etc/default/ directory lets you customize the default name.

If /boot/grub/grub.cfg doesn't exist, then /boot/grub/menu.lst should -- that's the GRUB Legacy menu file. It's reasonably similar to GRUB2's, in the sense that changing the boot order priority is just a matter of copying and pasting the various sections in the document into the desired order, or changing the default command to reflect the zero-based index of the desired default boot menu item. And of course you can change the name to whatever you want.

If the package tools detect that you have modified a GRUB menu item, generally they won't overwrite your changes automatically, so you don't have to worry about that. But even in the event that your changes are overwritten by a package upgrade, the changes you want to make are only "cosmetic", so it's not a disaster...

share|improve this answer
    
Thanks for the reply. I realized that I had not created a folder called /media/SHARED for the mount-point. Now after creating that, it is auto-mounting, but problem is only root can see it. For a normal user, it says "You do not have permissions". Any ideas what could be issue here ? –  Prahlad Yeri Aug 6 '12 at 22:27
    
See this question on Ask Ubuntu (the question and info contained there is not Ubuntu-specific). –  allquixotic Aug 6 '12 at 23:07
    
Sooo much head-scratching over such a trivial matter..:-)) Yes, this pretty much applies to my situation. And considering the risk this involves (like this guy's windows permissions got messed up), I have decided to let it be as it is. I don't want the auto-mount nicety if the consequnces could be that drastic!! –  Prahlad Yeri Aug 6 '12 at 23:30
    
Why not just use ntfs-3g? It doesn't have any concept of permissions. Just mount it with users flag and it won't touch permissions either way (it doesn't delete them but it won't read them either, it just leaves them alone). –  allquixotic Aug 7 '12 at 0:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.