Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Microsoft Word 2007, I'm getting this text rather than getting an actual hyperlink. How can I have it show the blue hyperlink instead? I'm currently using a "Print Layout" as my View. If I change it to "Full Screen Reading" View, I see the blue hyperlinks, but I'm unable to edit anything. How can I show blue hyperlinks while editing the document?

{ HYPERLINK "http://www.mysite.com" }
share|improve this question

2 Answers 2

up vote 6 down vote accepted

Press ALT+F9. You're in "Field Codes Mode", where Word displays field codes instead of the values of the fields.

More info: most dynamic data within MS Word is controlled by what Word calls "Fields", and fields are defined by programmatic data called "Field Codes". Field Codes are interpreted commands that Word processes in order to calculate data that is dependent on some value. One reason field codes are used for hyperlinks is that they change color once you've clicked them, from blue to purple, to let you know that you've already visited the site.

Other field codes include page numbers, e.g. { PAGE } and the table of contents, e.g. { TOC ... }.

You probably enabled field codes unwittingly by right-clicking on a field, e.g. a page number, and selecting "Toggle Field Codes" in the pop-up menu.

You can tell that a piece of text is a field (whether field codes are enabled or not) by the gray background that only appears when your insertion point (the blinking cursor) is moved over the field. You can toggle between viewing the field code and viewing the value by pressing Alt+F9 or by right-clicking as I described above.

share|improve this answer
    
Wish I double vote on this..thanks! :) –  Richard N Jun 25 at 19:40
    
What an answer! Thank you! –  Hoang Huynh Sep 1 at 17:05

To have the links appear as "normal" hyperlinks again across all your documents:

  1. Click on the Office Button in the top left corner of MS Word.
  2. Click on Word Options at the bottom of the drop down menu.
  3. Select Advanced.
  4. Scroll down and uncheck the box "show field codes instead of their values."

(That's in word 2007 I presume it would be a similar process in other versions.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.