Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a hard drive that is detected on Windows 7 but I cannot access it.

I plugged in the HDD and and I see it on the "Devices and Printers" but I cannot find it on my Computer.

Is clicked on it on "Devices and Printers" and found these details: Manufacturer: Unavailable Model: External HDD Model Number: Unavailable Categories: Storage Device Description: Unavailable

My HDD is Toshiba Fujistu

share|improve this question
1  
"Toshiba Fujitsu" is just the name of two large technology companies, and does not tell us nearly enough information about your device. The problem appears to be that it is NOT detected correctly, not that it was detected but not visible. You probably need some kind of driver, but without knowing something more specific, it's impossible to make a recommendation. The number of products that might be covered by "Toshiba Fujitsu" easily numbers in the hundreds of thousands. –  allquixotic Aug 6 '12 at 21:19
add comment

2 Answers

up vote 4 down vote accepted

Go to Control Panel -> Administrative Tools -> Computer Management -> On the left Side Under "Storage" click on 'disk Management"

From there there should be a list of drives and volumes that it detects. You may need to select the drive and right click on it and select "initialize" from there you can format the drive as NTFS.

share|improve this answer
3  
Bah, had that all typed out and you clicked submit first. :) –  Mark Allen Aug 6 '12 at 21:25
    
@cohortq : I tried to initialize it using booth options, but it says "The drive cannot find the sector requested" –  MIH1406 Aug 6 '12 at 21:27
2  
@MIH1406 Then either the drive is damaged, the disk controller in your computer is damaged, or you don't have proper drivers for the disk controller in your computer which the drive is connected to. –  Darth Android Aug 6 '12 at 21:35
add comment

I have only known a drive to be seen by Windows, but not be accessible if it had no drive letter associated with it (barring the drive is not damaged, usb cable not damaged and so on). This has happened to me due to the multi card readers with a "gazzilion" slots.

You could try this:

  • right click "computer"
  • Left click "Manage" (brings you to computer management screen)
  • Left click "Disk Management" - you should be able to see the disk with no letter, if that's the case.

  • Right click that drive, select "change letter and paths..."

  • Change letter - I suggest using a letter way down the alphabet as
    card readers/slots may have e:,f:, g: and so on... I like z: myself then work my way back to c:.

You may or may not have to format/initialize the disk from there, Windows will tell you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.