Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've moved my SVN repo from one host to another. The new host requires I commit by using svn+ssh:// instead of https:// like my previous host did.

One issue I can't escape is no matter what I do I get this error when I checkout or commit my changes:

To better debug SSH connection problems, remove the -q option from 'ssh' in the [tunnels] section of your Subversion configuration file.
Network connection closed unexpectedly

I've modified the config file located on my home drive and on the root area, I still get that message.

now odd enough, I was able to get the repo by using command line but if I use either gui tool i have on my linux box i get that message.

I'd HIGHLY prefer not having to commit by command-line, so if anyone can tell me how I remove that -q flag it seems to keep saying exists, it will make my day.

currently both config files have the value setup like so, let me know if its wrong:

ssh = $SVN_SSH ssh -o ControlMaster=no

I did it with both the # sign in placed and removed.

I'm out of ideas and need some insight.

Thanks in advanced.

share|improve this question
    
A very common reason for this error is that the svn URL is improperly formatted--like a missing username etc. What URL are you using in the new configuration? –  ephsmith Aug 7 '12 at 0:56
    
the instructions was written for cli usage, so i took out the cli stuff like svn checkout --username=xxx and just used the svn+ssh:// url for the url. –  php-jquery-programmer Aug 7 '12 at 1:11
    
I tested the same url on my windows machine, it works just fine, so now I'm stumped. I do 99% of my work on linux so it'll help if it works there too. –  php-jquery-programmer Aug 7 '12 at 1:26

1 Answer 1

up vote 0 down vote accepted

I found out the gui tool i'm using has a known problem with that sort of svn connection, but I've noticed netbeans svn tool works, so I'll just use that until RabbitVCS resolves that longstanding bug.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.