Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have 2 old hard drives (they are both ATA) and I have one ATA ribbon cable with 2 connector. I install Linux on one harddrive and Windows 7 on the other. I can use them by switching the harddrives.

I am wondering if there is a way to dual boot them like using grub. I guess I need to set one's jumper and make it master and another slave. Then, how can I change the boot records... I don't know how to do it? Do I need some other tools?


stuff I tried

set jumper on Linux drive to be master set jumper on Windows driver to be "cable selected" (that's the only option other than master, no slave option)

I am not sure how to connect the ribbon cable. There are 2 connectors, say, A and B. So I tried both cases, A-Linux, B-Windows as well as A-Windows, B-Linux. It complains that no bootable devices for both cases?

I am really really confused!!! I remember trying this before and it didn't work. So I gave up and today I am trying and it failed again. Am I running out of options?

A progress. The label print on the harddrive doesn't tell how to make it slave. There I chose "select by cable". It turns out that if I removed the jumper at all, it will be slave!!!

The next question is how to modify menu.lst at /boot/grub?

Thanks! Alfred


Solution I found

Finally I got it working!

  1. So 1st of all, connect the HD as slave correctly. For my case, I need to remove the jumper even the label doesn't tell "hey, that is how slave is connected!"

  2. Linux HD should still be the master as alway.

  3. When turning on the computer, BIOS should show that 2 drives are detected. That means the connection is right.

  4. In Fedora 13, /boot/grub/menu.lst, add this for the Windows

title Windows 7

root=(hd1,0)

savedefault

chainloader +1

And then, dual booting works magically! Hope that helps to someone would like to do similar stuff.

Thanks for everybody who gave me suggestions!

Alfred

share|improve this question

migrated from stackoverflow.com Aug 7 '12 at 1:27

This question came from our site for professional and enthusiast programmers.

    
ya, you should make one of your driver master which contains a boot menu to access your secondary drive. I think this is the best way to tackle this problem –  Ryan Fung Aug 7 '12 at 1:17

2 Answers 2

Yes you can. If you put the Linux drive in the master position on the cable, it maybe easier.

You actually have not given enough information; you should have told us what distribution you are using. Your Linux install probably already has a boot loader on that disk. If you installed a full feature desktop the boot loader is probably one of the following: Grub, Grub2, LILO.

I am going to guess and assume your using Ubuntu and link you here. https://help.ubuntu.com/community/WindowsDualBoot

If you give information you will get better help.

Actually there is a link on that page that is probably more suited to you, but you should read that page to get a better understanding. This page is about re-installing the boot loader after having installed windows. Really you will be informing a working boot loader about windows as a boot-able partition option. https://help.ubuntu.com/community/Grub2#Reinstalling_GRUB2

share|improve this answer
    
Thanks! I am using Fedora 13, I think the bootloader should be grub. Do I need to edit menu.lst? –  Alfred Zhong Aug 7 '12 at 1:54
    
That sounds like what I would do. However searching around i found that Fedora dual booters like to use windows boot loaders and add the fedora record in there. Also edit the original post with the additional info. –  AeroJoe Aug 7 '12 at 2:02
    
I tried setting the Linux drive as master, using the jumper, and the Windows drive as slave. I am not sure how to connect the ribbon cable. But I tried both cases. Neither way worked. It keep complaining no bootable device... WTF?! –  Alfred Zhong Aug 7 '12 at 5:29

had the same problem with SliTaz and Windows XP - so XP is on 1st HD (by jumpers as MASTER configured) / 1st Partition (sda1) and SliTaz (Linux) is on 2nd HD (by jumpers as SLAVE configured) / 1st Partition. What I found - when installing a 3rd OS on 2nd HD / 2nd Partition - is that GRUB always uses the menu.lst on the last Linux partition you installed. So you have to change the menu.lst there.

This config is working with 3 OS installed (1 XP and 2 SliTaz):


# For booting SliTaz from : /dev/sdb1
#
title SYSTEM 1 - SliTaz GNU/Linux (cooking) (Kernel vmlinuz-2.6.37-slitaz)
root (hd0,0)
kernel /boot/vmlinuz-2.6.37-slitaz root=/dev/sdb1 quiet

# For booting SliTaz from : /dev/sdb2
#
title SYSTEM 2 - SliTaz GNU/Linux (cooking) (Kernel vmlinuz-2.6.37-slitaz)
root (hd0,1)
kernel /boot/vmlinuz-2.6.37-slitaz root=/dev/sdb2 quiet

# For booting Windows from /sda :
#
title Microsoft Windows
    map (hd0) (hd1)
    map (hd1) (hd0)
    rootnoverify (hd1,0)
    chainloader +1
    boot

As both OS are only booting from the FIRST partition of the FIRST HD I had to "map" the drives.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.