Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For a week or so I've hit a strange issue with my Windows 7 64-bit machine.

Intermittently I get a problem with the cursor auto scrolling to the right. It's almost like the right arrow key is stuck down (but it's not! ). It happens across all apps/Windows. If I click in to a drop down list on a web page it auto scrolls to the bottom. Click in the Windows Sys Tray and it goes all disco as it flashes endlessly through all of the icons.

I've tried different keyboards, removed all keyboard/mouse drivers and re-installed. I've manually removed InterlliType/IntelliPoint and dropped on the most recent versions all to no avail.

It can take anywhere from 5 minutes after boot up to a couple of hours before it happens. I can clear the issue by doing Ctrl-Alt-Del and Switch User before logging back on.

AV/Malware checks have come up clear from a number of products. I tried a clean boot (via msconfig) and still saw the problem albeit less frequently.

Has anyone come across anything like this. I'm not going to spend too long fighting it - as I do the bulk of my work in VMs I'll just rebuild the host but thought I'd ask in case I end up seeing the same issue again after the rebuild.

I've also tried adding the environment variable to show all hidden/inactive devices and removed all of those in Device Manager as well.

UPDATE:

I decided not to waste any more time on it and did the rebuild. All seemed great last night as I worked for a couple of hours with no issues setting my machine up again. Then as I power on this morning the bug is back after only a minute of use!

I've not even reinstalled all my usual software yet. It's a clean install, SP1 and then I've dropped on Office 2010, Skype, Watchguard VPN client, Chrome, Skydrive, UltraMon and DropBox.

I'm baffled - could this indicate that it actually is some kind of hardware issue?

UPDATE:

Current thinking is a windows update conflicting with my kit. Haven't nailed down which one yet but a roll back to an earlier restore point seems to be bug free. I'm slowly putting stuff back on and will probably just have to step through updates one at a time to try and spot which one causes the issue.

UPDATE:

Still happening on the rebuilt machine. An interesting point, the bug has now decided to change from being the right arrow key to the 0 key repeating!

When I clicked in to a couple of running VMs I found that XP was also showing the 0 bug but in W7 VM it was actually still doing the right arrow key!

share|improve this question
    
It's not the mouse pointer - it's the cursor/caret that is moving on it's own... ... and when it happens it stays in the faulty (stuck key) state. –  Chris W Aug 7 '12 at 10:57
    
It DOES happen inside the VMs as well though strangely I've observed some occasions where the VM is ok but the host machine is in the buggy state. –  Chris W Aug 7 '12 at 11:01
    
A quick search indicates this could be graphic card issue (I don't know how)! Can you make sure ALL drivers / Win Updates are complete (if possible)... Also, can you try a different USB port? I wonder if the physical port is 'faulting' (assuming it's not PS2) –  Dave Aug 7 '12 at 11:02
    
Everything is USB and I've moved things to different ports already. Everything is up to date but I'll have a look at the graphics card tip. –  Chris W Aug 7 '12 at 11:07
1  
Have you tried a different mouse, or even a using it on a different surface? –  leaf68 Aug 7 '12 at 11:39

3 Answers 3

Just suggestions more than an answer:

Can you open Keyboard in Control Panel -

Under Speed, make sure the text box is empty and maybe just move the Repeat delay and Repeat rate slightly along just to see if this has any impact.

From within the same window, under hardware make sure the device is working properly. And then from here, click properties. In the new window, click on power management and make sure it's all unchecked.

share|improve this answer

After reinstalling evrything I figured out that the mouse has a left/right scroll as well as up/down. The right scroll sensor on my mouse was brocken. I bought a new Logitech mouse for 7€ and all is good again.

share|improve this answer
up vote 0 down vote accepted

In the end I gave up with attempts to resolve this and wrote it off as a hardware fault.

My gut feeling is that it was mobo related. Thankfully work were happy for me to just replace with new kit and get back to actually writing code instead of fighting this issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.