Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

On a new installation of IIS 7.5 I have setup Windows Authentication on my Intranet.

The providers I have used are 'NTLM' and negotiate in that order.

This works fine in IE and Firefox but in chrome I get the following

This web page is not available The web page at http://mysite.com/myintranet.php might be temporarily down or it may have moved permanently to a new web address. Error 338 (net::ERR_INVALID_AUTH_CREDENTIALS): Unknown error.

I've tried looking online for a solution without any success.

I'm running the latest version of Chrome 21.0.1180.60

share|improve this question
    
I would delete your cookies / temp files from Chrome and try again –  Dave Aug 7 '12 at 14:17
    
I've tried this but it has had no effect. –  Sam Aug 7 '12 at 14:21
    
I have a similar issue with IIS 8.5 and Chrome. All other browsers work fine. Chrome rejects the auth (logs show it doesn't pass a username). So if it's the same issue and you fixed it, I would like to know what you did. –  sevenalive Mar 11 at 18:05
    
Remove "negotiate" completely - don't just move it down the list. It's and old question, I know, but I came up against this today, on an IIS server that was, until now, authenticating all browsers just fine. –  thinkOfaNumber Sep 8 at 2:17

1 Answer 1

This is a very well known and old issue. However, Shawn Weisfeld provided a year ago a solution on his blog:

The fix was to force the web server to use NTLM. To do this in IIS 7 is just a setting in system.web/system.webServer/security/authentication/windowsAuthentication/providers section of the web.config

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.