Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

About a month ago, Facebook stopped loading on any browser on my Windows 7 PC. I figured it was a virus, and yesterday, I wiped my computer clean and formatted everything because the entire thing has been sluggish lately.

I am typing this on my freshly wiped Windows 7 Ultimate x64 computer, and the only program that I have even installed yet (beside the drivers) is Google Chrome. I can't load Facebook even on this wiped-clean computer. It loads on my freshly wiped laptop, my iPad, my iPhone, and every other computer on my network. It just won't load for this one physical machine. I even tried rearranging Ethernet cables on my router, changing the Ethernet cable going to this computer, and resetting the network.

Absolutely nothing fixes this. I have literally no idea what could be causing this.

Keep in mind that this is happening to one computer with a brand new install of Windows and every other website works on this computer. Every other device on the network can also connect to Facebook.

share|improve this question
1  
What do you mean "doesn't load"? What happens when you try to go to facebook? Describe exactly what happens. Do you get an error message? If so, what error? Does it just display a blank page? If you go to View Source on the resulting page / non-page, what does it say? –  allquixotic Aug 7 '12 at 15:41
    
Can you define 'not loading'? Does it leave you a blank page? Does it give you an error? Also, what version of Chrome are you using? Just the download from google's website, or have you switched it to the beta or dev channels? –  Darth Android Aug 7 '12 at 15:41
    
I type in "facebook.com" into the address bar and then Chrome tells me "This webpage is not available" because it took too long to respond. Occasionally, (before I wiped my computer and was still logged in) it would let me go to the homepage, but it wouldn't even load the News Feed. –  Nick Anderegg Aug 7 '12 at 15:43
    
Can you confirm sites other than Facebook load correctly? –  ultrasawblade Aug 7 '12 at 15:46
    
Every other site loads correctly. I was evening doing a full-system backup before I wiped my computer, which meant sending a ton of data to the cloud. –  Nick Anderegg Aug 7 '12 at 15:55

3 Answers 3

up vote 6 down vote accepted

Things to try:

  • Try running ping facebook.com from your broken computer and from a computer that accesses it successfully. Do you get the same IP address when it looks up the hostname on both computers? Can the broken computer resolve an IP at all?

  • Try other websites with dynamic content

  • Make sure the router doesn't have any type of content filtering on it that may be blocking you out...

  • Do you trust the users of all the other computers on your network? Someone may be doing something nasty.

  • Make sure your drivers are up to date. Drivers shipped on the CD that comes with the hardware are often minimally working, just enough to convince the customer that the hardware isn't dead, but they often are chock full of bugs. The bugs get fixed in subsequent driver releases which are pushed on the manufacturer's website.

The latter bullet happened to be the issue with the original poster, so I bolded it. You can see the diagnosis chat in the comments.

Googlers: welcome to driver heck ;-) Go to the manufacturer website (in the OP's case, Asus) and update your drivers!!! Some keywords:

Realtek 8111E slow Asus M5A97 ethernet slow Driver CD network slow

share|improve this answer
    
Every other website loads fine including Twitter, SE, Quora, and Gmail which all load content dynamically. There's no content filtering on my router. I double checked even though I'm the administrator on this network, and there is not type of filtering. And nobody is doing anything. This happens even when all other devices are off. The desktop and laptop are pinging different IP addresses however; with the laptop about 80ms faster, but they could just be connecting to different Facebook servers. –  Nick Anderegg Aug 7 '12 at 16:02
    
Are both your laptop and the broken box hitting the same DNS server? Check your network settings and make sure they are hitting the same DNS server. Also try reverse DNS lookup of the IP address returned as "facebook.com" by the broken box. If the reverse DNS doesn't indicate that it's facebook, you may have lingering malware trying to redirect you to a malicious site. mxtoolbox.com/reverselookup.aspx –  allquixotic Aug 7 '12 at 16:05
    
Here's what the broken box is giving me: mxtoolbox.com/SuperTool.aspx?action=ptr%3a69.171.224.37 and here's what my functioning laptop is giving me: mxtoolbox.com/SuperTool.aspx?action=ptr%3a66.220.158.11 Different nameservers, but otherwise, no issues. –  Nick Anderegg Aug 7 '12 at 16:07
    
Try directly accessing the 66.220.158.11 that the functioning laptop gives you, from the broken box. Does that work? –  allquixotic Aug 7 '12 at 16:10
    
I just refreshed Facebook, the homepage loaded almost instantly, I tried logging in, and it was very, very quick to tell me the page took to long to load. Why is my browser instantly telling me a page is taking too long!? That doesn't even make sense. –  Nick Anderegg Aug 7 '12 at 16:10

I was having the same problem but with my twitter account. It turns out that AVG was set to block every cookie from Twitter so it won't let me follow/rt, anything. As soon as I changed that set to enable cookies it magically worked again :P

share|improve this answer

To me it sounds more like either your security software or a malware is preventing you from accessing Facebook.

  1. Try making sure that Facebook is on your allowed/safe list on your AV software/firewall (somebody/something could have placed it on the blocked list).

  2. Scan your PC for malware using your AV with latest definitions.

share|improve this answer
1  
Wow, I wish StackExchange had a "Did not read the question" badge. I'd totally give it to you. The problem was occurring on a blank install of Windows with nothing installed whatsoever, and the problem was already solved by the answer above. –  Nick Anderegg Aug 16 '12 at 18:40
    
Sorry for misreading, Nick. –  Bobster Oct 8 '12 at 15:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.