Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running a dual-boot with windows-7 and debian squeeze 6.0.5. Initially I had just two windows partitions (C: & D:). Of them, I formatted the D: as ext4 and installed squeeze using the debian installer.

Debian installed grub which boots both OSes which is fine. However, I've noticed in Win7 that when I go to Control Panel=>System=>Advanced System Settings=>Startup & Recovery Settings, my Default OS is showing blank. There is no option in that dropdown. Is this behaviour normal or do I need to fix something?

share|improve this question
up vote 2 down vote accepted

This is likely an artifact of installing Debian's GRUB bootloader into the Master Boot Record of the default boot-up hard drive, which is most likely your Windows drive.

If Windows can't detect its bootloader, it will display nothing in that dialog that you refer to.

When I dual boot, I prefer to keep each operating system isolated on its own disk. That is, I let Windows own the MBR on its hard drive, and I let Linux own the MBR on its hard drive. That way, you can remove one of the hard drives, and the operating system that remains can boot on its own.

The way you have it set up, I believe that if you took out your Linux drive and tried to just boot the Windows drive, it would say something like "GRUB" when booting up, or would give you a minimal GRUB shell from which you'd have to enter something like:

root (hd0,0)
chainloader +1

in order to boot your Windows drive (if you're lucky; that may not even work).

You could probably boot up a Windows repair console and run fixboot to restore the Windows MBR, then install GRUB on the hard drive running Debian, to get a configuration similar to how I have it. But if you don't plan on removing one of your hard drives, then your current setup will continue to work fine.

Hi, BTW. I think I answered a question for you yesterday. :)

share|improve this answer
Yes. that & this questions relate to the same dual-boot installation :-) – Prahlad Yeri Aug 7 '12 at 17:26
I think your solution will work when there are two hard-drives and two corresponding MBRs. I've already mentioned that I have just one hard-drive which is divided into two separate partitions. Also, I've heard that win-loader in MBR causes problems in booting linux. Thats the reason I chose to install GRUB in MBR that currently boots both windows-7 & debian. – Prahlad Yeri Aug 7 '12 at 17:31
Oops, I misread your question. Yeah, with one hard drive, using GRUB in the Master Boot Record is definitely more advisable than using NTLoader in the MBR. So Windows will basically be dead-headed and always thinking "I don't have a boot loader" because, well, it doesn't. :) – allquixotic Aug 7 '12 at 17:32
I've had mine set up like this forever and never noticed that. It shouldn't cause any issues. Make sure you either reinstall the windows MBR BEFORE you remove linux if you decide to, or have an extra computer handy to get instructions for it. – Rob Aug 7 '12 at 18:28
Actually I have noticed one more inconsistency since my dual-boot install. win7 refuses to hibernate since GRUB2 has become the bootloader. Turns out that win7 needs the first partition of the hard-disk to be marked with "boot" flag. This gentleman at ubuntu forums suggests an excellent hack ( After doing that my both issues are solved now, win7 hibernates and shows itself as the Default OS. Grub will work as usual w/o issues since it is sitting in the MBR! – Prahlad Yeri Aug 7 '12 at 20:08

There's a very big difference between two physical hard drives and simply partitioning one physical hard drive. You said this was all on one physical hard drive so the advice sllquixotic gave is not really all that good because he/she assumes you have two physical hard drives.

Of course, having 2 physical drives may be the best way to go. Cause with two drives you just select the default boot device in/from your BIOS and off you go. Just be sure and not have both connected when you install either OS or try and fix boot problems. Now, you can complicate a dual drive setup like that if you want with GRUB, but it's a bit idiotic to do so. If you ask me, having two physical hard drives in a dual boot rig is exactly why you want two - so you don't "grub-up" your Windows!

Now when Debian is installed it also usually installs a different boot manager called GRUB. And GRUB very likely took over what the Windows boot manager had been doing. So if Windows 7/Vista was previously installed (and was installed using it's default settings) then there is a 100Meg boot partition or boot "drive" that the Debian installer needs to deal with. This partition is not only small it's also hidden by not assigning it a drive letter. (Windows also likes using it to save system restore data on too.) But that doesn't mean it won't have the boot flag assigned or not be able to pass any further booting to another partition. And that's just what GRUB wants to do. GRUB will either be installed to the "boot" partition or simply redirect the boot flag (done in the MBR) to another partition of wherever the GRUB configuration files will be.

So to put it more simply, Windows won't know what the default OS is simply because it's own boot loader is no longer in control - GRUB is. So in that respect, allquixotic is right.

Allquixotic is also right as far as "chainloading" goes too! But don't forget. There are two drives in his/her system.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .