Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
I can't delete a file - even when using unlocker

I tried all the tools from the question How do I delete a 'locked' file?, and they didn't help.

All the software suggested to download attempted to unlock my file, but they all failed. Additionally, booting into safe mode still didn't solve my problem.

When I try to delete the file (an ISO image that I created of the Windows 8 Install Checker), I get this error:


I obviously can't end System.exe, that'd crash my computer. I've been trying to remove it daily, and it won't let me delete it, even right after a restart.

It's stored on my desktop, and I can't move it, because I get that error.

share|improve this question

marked as duplicate by harrymc, Dave, Indrek, BBlake, bwDraco Oct 2 '12 at 13:04

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

@slhck none of the other answers worked, so I flagged for re-opening. Thanks for bringing that post to my attention, though, I didn't find it earlier! At least I now know what won't help. – Frank Aug 7 '12 at 19:43
Please include more information that just "it didn't work". This'll provide valuable information for others in attempting to solve your problem. – Daniel Beck Aug 7 '12 at 19:45
Is only this one file affected or other files as well? What types of files are affected? Only .iso? Are all files on the same partition? Maybe even the same folder? – Oliver Salzburg Aug 7 '12 at 20:07
Only this exact file. The .iso is a iso version of the Windows 8 install checker, so it doesn't run (I didn't understand what the iso would do when I made it). – Frank Aug 7 '12 at 20:16
You said you tried all the suggestions from the other answer. When you run Process Explorer, make sure you run File -> Show Details for all Processes. Then search for win8install.iso (Ctrl+F). Does it find anything? If so, what process/service does it highlight? – Oliver Salzburg Aug 7 '12 at 20:31
up vote 2 down vote accepted

You can schedule the file to be delete the next time you boot. It will be deleted early in the boot process, before any programs access it. I prefer BitSum’s tool movelater; for example:

movelater C:\Users\Chippery\Desktop\win8install.iso /d

You can also use Sysinternal’s MoveFile:

movefile C:\Users\Chippery\Desktop\win8install.iso ""

That takes care of the file, but that it is always locked by the system process when you boot indicates an ongoing usage which may cause problems if you delete the file and the system tries to access it.

Because the system process is the one locking it, it is likely a driver that is using it. Because it is an ISO file, it seems that you have mounted the disc image in a program that is using a driver to emulate a CD/DVD.

As curmil suggested, it is best if instead of just forcing a delete of the file on boot, you run the mounting program and unmount the image and you should find that the file is no longer in use. If it is, then a reboot should free it up, without needing to resort to the above tools.

share|improve this answer
Thanks, I'll try this. Do I run it in a .bat file? Using it in cmd says that movefile isn't a recognized command. – Frank Aug 7 '12 at 21:26
No, the command-line is fine (though you will probably have to open an admin one). They are not built-in commands, you need to download the tools. – Synetech Aug 7 '12 at 21:36
So did you try it? – Synetech Oct 3 '12 at 18:17

Is it possible that you've accidentally mounted the ISO to a virtual drive? If so you might just need to unmount it before trying to delete or move the file.

share|improve this answer

You can try with disabling the virtual drive listed in the device manager or if you can change the extension to something different could help you to delete that file.

Hope it helps.

share|improve this answer
In Windows 10 - If you are using Hyper-V it will also lock the ISO files, and they will appear as in use by System. This is fixed by un-mounting the ISOs in Hyper-V Manager. – IceMage Jan 6 at 18:40

If nothing else works, linux live cd/usb is definitely an option. Boot up a Linux live USB and just deleted from there.

share|improve this answer
That doesn't help. – Frank Aug 7 '12 at 19:31
What I did when shooting down all processed didn't work - I booted up a Linux live USB and just deleted from there. If nothing else works, that's definitely an option. – kranberg Aug 7 '12 at 19:38
@kranberg Turned your comment into part of your answer so you can get votes if it works – Canadian Luke Aug 7 '12 at 20:21
@Luke Thanks! It's a possible solution. – kranberg Aug 7 '12 at 21:03
@kranberg That's why I figured I'd add it for you – Canadian Luke Aug 7 '12 at 21:19

Not the answer you're looking for? Browse other questions tagged .