Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am getting the following error when I try to run iTunes.

---------------------------
Newer Version of QuickTime Required
---------------------------
QuickTime version 7.6.2 is installed, iTunes requires QuickTime version 7.6.4 or later.

Please uninstall iTunes, then install iTunes again.
---------------------------
OK   
---------------------------

I have uninstalled iTunes and reinstalled from latest version from the apple website, I have tried apple update and installed all that.

Any ideas?

Update: Thanks for all the suggestions, I guess I was just annoyed because the error message is so rubbish. When I get a chance I'll reinstall them all.

share|improve this question
up vote 3 down vote accepted

Try uninstalling QuickTime, then re-downloading the latest version of QuickTime 7 from apple.com. You may need to re-install iTunes after installing the new version of QuickTime.

share|improve this answer

Open QuickTime and check your version. If it is out of date, update it and try again.

share|improve this answer

This is so stupid.

Despite iTunes being a single download, in order to uninstall it you need to uninstall iTunes and Quicktime, then reinstall itunes. Finally it is working.

Thanks for help.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .