Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a new Core i3 notebook with Windows 7 Home Editon 64-bit. The PC ran fine for several months, but since a week, every time I try to open a folder on Explorer it takes almost 30 seconds to open.

So far, I've tried:

  • checking for virus or spyware with MS Essentials, MalwareBytes and DrWebCureIt (no virus or spyware)

  • restoring to a previous System Restore Point

  • chkdsk /f (no errors)

  • disabling Windows Search (no difference)

  • sfc /scannow on a elevated command prompt. Stops with an error:

    Windows Resource Protection could not perform the requested operation

  • disabling Active Destkop via registry (as explained in How to Disable or Enable Active Desktop in Windows 7)

  • disabling every non-Microsoft startup program via AutoRuns

  • disabling non-Microsoft shell extensions via ShellExView

  • removing USN JOURNAL with fsutil usn deletejournal /D C: because Sysinternals Process Monitor shows a delay of 5+ seconds on SFTLIST.EXE / FileSystemControl

The freeze is only in explorer.exe, I can switch to another processes without any slowdown. There are no CPU spikes in Task Manager or Process Explorer.

I discard hardware errors because if I start in Safe Mode the PC ran fine. I cannot do a repair install because Windows (Home Premium) is preinstalled in the notebook and I have no Windows CD.

What else can I try without having to reinstall Windows?

share|improve this question
    
Is this happening with every folder, or only certain ones? –  Markus Orreilly Aug 7 '12 at 22:29
    
@MarkusOrreilly: this is happening with every folder I try to open with Explorer. If I navigate the folders with Total Commander -for example- it works fine. –  PabloG Aug 7 '12 at 23:12
add comment

3 Answers

  1. Run Process Monitor.

  2. Enable Duration column.

    enter image description here

    enter image description here

  3. Start Explorer.

  4. Wait for the delay to pass.

  5. Stop recording events in Process Monitor (Ctrl+E).

    enter image description here

  6. Open the Filters (Ctrl+L).

    enter image description here

  7. Add a new filter that includes all items with a Duration of 1 or more.

    enter image description here

You will now see only those events, that took longer than 1 second to complete. This may be able to give you an indication about what is delaying the start of Explorer.

If there are still too many events listed, you can increase the duration in the filter.

You can also try to read through the log and see what explorer.exe is doing when it starts.

share|improve this answer
    
that's exactly the way I found the processes that takes 5 seconds (only that I filtered with 0.5 sec). The process/operation listed -as posted- is SFTLIST.EXE / FileSystemControl with 5 or more seconds –  PabloG Aug 7 '12 at 23:08
    
@PabloG: Does it show only 1 entry in the filtered results? Or are there multiple operations performed by sftlist.exe that each took 5 seconds? And most importantly, what operations were those? –  Oliver Salzburg Aug 7 '12 at 23:10
    
there are four 5 sec+ operations for each Explorer click on a folder: the process is SFTLIST.EXE, the operation is FileSystemControl. Before I disabled the USN Journal, the operation was USN_JOURNAL_UPDATE or something like that (didn't saved the log) –  PabloG Aug 7 '12 at 23:54
    
@PabloG: What does it say in the Details column for those sftlist.exe processes? –  Oliver Salzburg Aug 7 '12 at 23:59
    
@PabloG: The process seems to be the Application Virtualization client service. From what I've been reading about it, I don't think I've ever used it. I'm not finding any similar issues online right now. Could you check the event log regarding this service? –  Oliver Salzburg Aug 8 '12 at 0:05
show 2 more comments

Wow, that's quite the list of things you've tried. One other thing I would try as more of a diagnostic step would be to force-kill explorer.exe and then start it again. If it behaves differently, it might give you some additional info to go off of.

Force kill explorer.exe:

taskkill /f /im explorer.exe

Then start explorer.exe just by running it:

explorer.exe

If I think of anymore things to try I'll put them in here as well.

share|improve this answer
    
yeah, I did it, no luck –  PabloG Aug 7 '12 at 23:05
add comment

If sfc is returning

Windows Resource Protection could not perform the requested operation

I assume you didn't do a full sfc scan? Why don't you try the suggestions here to get sfc /scannow to work again.

If that doesn't help, uploading a full Process Monitor log of what happens when you start up Explorer could help diagnose the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.