Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Just install RealVNC free edition and I can't connect when it's running as a service because there is no password set. When I run "VNC Server (User Mode)" I can connect fine. How can I set the password for the service?

Googling didn't turn up any answers. Running server on Windows 7 ultimate and client on Windows XP.

share|improve this question
up vote 6 down vote accepted

When in service mode, you should have a task-bar icon:

  1. Right click over the task-bar icon;

  2. Select "Options...";

    Right Mouse Click Over VNC Icon Screen Shoot

  3. If UAC is active, select yes;

  4. From the window presented, access the first tab "Connections";

  5. Click on Configure...;

    Options Screen Shoot

  6. Set your VNC Server password, repeat the password and press ok;

    Set Password Screen Shoot

You're set, you should now be able to connect to your VNC Server with the password you've just set.


ENABLE / DISABLE Tray Icon

If you don't see the tray icon, you can activate it using the windows Registry editor:

  1. Click "Start";
  2. On the search box, type "regedit" and press enter;
  3. On the left column, navigate to:

    HKEY_LOCAL_MACHINE\SOFTWARE\RealVNC\vncserver
    
  4. On the right, you should now see a REG_DWORD Value named "DisableTrayIcon";

  5. Right click over it and select "Modify...";
  6. The value should be set to "1", replace it with "0" to show the tray icon;
  7. Press OK, as soon as you press it, the tray icon should appear.
share|improve this answer
    
no tray icon when running the service- only when running the "user mode" server? – Lee Tickett Aug 8 '12 at 12:04
    
@LeeTickett I've got a tray icon in service mode, I'll check for other options. – Zuul Aug 8 '12 at 12:05
    
@LeeTickett You've configured windows to run VNC as a system service? – Zuul Aug 8 '12 at 12:14
    
it installed a service by default and the service is running – Lee Tickett Aug 8 '12 at 12:20
1  
Similar thing I ran into -- While in Service-Mode the VNC tray icon isn't visible when you RDP into the system, unless you tell RDP to connect to the console. – Ƭᴇcʜιᴇ007 May 7 '13 at 14:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .