Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Debian Wheezy today.

when i boot Debian wheezy when splash logo about to open, the screen blanks and system hangs, but Debian stable was booted without errors, but

I changed init parameter to init=/bin/sh, Then mount -o remount,rw /

its all ok, but when i try to start x server with this command:

Xorg

The screen is blank and system locked.

There isn't a /etc/X11/xorg.conf and /etc/X11/xorg.conf.failsafe

What i tried so far:

copied https://launchpadlibrarian.net/21150771/xorg.conf.failsafe to /etc/X11/xorg.conf, when i start Xorg it says no screens found, when i reboot without touching init= command, the screen is still hang and blank at bootup logo.

Tried Xorg -configure, generated xorg.conf but not worked.

What i can do? P.S. i have readon 2600 HD pro

share|improve this question

2 Answers 2

xorgsetup # menu wizard for easy xorg config

startx # start X

dmesg | tail -n 30 # if start x fail, show dmesg

grep \(EE\) /var/log/Xorg.0.log # xorg log, errors should be here

share|improve this answer
    
Getting xorgsetup and Xorgsetup not found error –  Burak Tamtürk Aug 8 '12 at 14:01
    
from google: dpkg-reconfigure xserver-xorg or X -configure instead of xorgsetup. I am not familiar with Debian. –  okobaka Aug 8 '12 at 14:41

Please post the output of the following command:

grep -A3 -B3 "(EE)" /var/log/Xorg.0.log

That's a way to get the lines containing (EE), which are important as they indicate errors. The command will also include 3 lines before and after each error, just to get a little bit more context.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.