Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have an FDL file which is used to offer an online application possibility. The FDL is filled out and sent to a mailbox.

When I open the received file, Adobe Reader starts, loads the document in Internet Explorer (had to change my default browser because it doesn't work in chrome - the customer uses IE as default) and displays a warning that Adobe Reader has blocked the connection to the server where the initial document is saved:

enter image description here

I can then click on "Trust this document once" (translated by me!) or "Add this host to trusted hosts" (also translated by me!).

The second option doesn't work at all. The first option works but is a little bit annoying.

I looked into Adobe Readers options (Edit -> "Voreinstellungen" in german / the last option -> Security (advanced)) and found the possibility to add hosts, files and directories or allow Adobe Reader to use the "Trusted Websites" list from Internetoptions. When I add the website either to Trusted Websites or the trusted list in Adobe Readers options, the warning doesn't pop up but the content in the prefilled (by the applicant) input boxes of the document doesn't show up on Windows 7 but it does show up on Windows XP.

This Screenshot shows the settings window described in the last paragraph. The big input box at the bottom normally holds the trusted files/directories/hosts list.

enter image description here

System Information:

  • Windows 7 Enterprise x64
  • Adobe Reader X
  • multiple IE versions (mine is latest but there's also IE 7 or 8)

How do I get Adobe Reader to load the content of the form?

This behaviour can be reproduced on a PC. When opening an fdf from a command line the form fields are blank even though there is data in the fdf and the pdf is located in a mnaully entered trsuted folder.

Steps to reproduce:

  1. Clean install a Windows 7 PC (or use a virtual box)
  2. Map a network drive to a shared folder with a subfolder e.g. c:\test\docs becomes m:\docs
  3. Set security permissions to allow full control to everyone
  4. Add an fdf and a matching pdf file in the subfolder
  5. Manually add m:\docs to each of the trusted folders in the trust manager registry settings
  6. Ensure that Enhanced Security is on
  7. Run a command line to open the fdf file

Expected result:

  • pdf is opened in Adobe Reader with form fields filled out with data

Actual results:

  • pdf is opened with blank fields
  • 'Yellow bar' appears asking to add document to trusted locations

It appears that Adobe Reader XI is ignoring the privileged locations entries in the registry. Adding the document via the 'yellow bar' adds the individual document, with the same folder, to the privileged locations but means that the process has to be repeated for every document that needs to be opened from the folder.

share|improve this question
    
Bother. I've got a very similar problem in that Adobe Reader won't trust a network location/shared folder that I add to the 'trusted folders' / privileged locations box and shows a blank form when opening an fdf file from the command line. The yellow bar shows and allows me to add a single file (with the same bloody path) but it won't let me store a folder. –  Clara Onager Nov 12 '12 at 8:53
    
Did you find a solution to this problem? –  Clara Onager Nov 12 '12 at 9:08
    
See also forums.adobe.com/thread/1098771 for an example of how you can reproduce this problem –  Clara Onager Nov 14 '12 at 10:08
    
I know this may not help you, but Adobe Reader is a really bad piece of software compared to what competitors offer. I have been using Foxit Reader some time now, and I've already noticed SO many positive differences. –  MDeSchaepmeester Nov 20 '12 at 18:32
    
Hardly any develper would choose to use Adobe Reader, it's almost always forced on us by management and a lack of decent alternatives –  Clara Onager Nov 21 '12 at 10:25

1 Answer 1

The only answer I've been able to discern so far is that this is a bug in Adobe Reader and thus there is no way to fix this problem.

Update: After much experimentation I have found a workaround. I've included my edit to the question in case it isn't approved by the OP and to provide context.

How do I get Adobe Reader to load the content of the form?

This behaviour can be reproduced on a PC. When opening an fdf from a command line the form fields are blank even though there is data in the fdf and the pdf is located in a mnaully entered trsuted folder.

Steps to reproduce:

  1. Clean install a Windows 7 PC (or use a virtual box)
  2. Map a network drive to a shared folder with a subfolder e.g. c:\test\docs becomes m:\docs
  3. Set security permissions to allow full control to everyone
  4. Add an fdf and a matching pdf file in the subfolder
  5. Manually add m:\docs to each of the trusted folders in the trust manager registry settings
  6. Ensure that Enhanced Security is on
  7. Run a command line to open the fdf file

Expected result:

  • pdf is opened in Adobe Reader with form fields filled out with data

Actual results:

  • pdf is opened with blank fields
  • 'Yellow bar' appears asking to add document to trusted locations

It appears that Adobe Reader XI is ignoring the privileged locations entries in the registry. Adding the document via the 'yellow bar' adds the individual document, with the same folder, to the privileged locations but means that the process has to be repeated for every document that needs to be opened from the folder.

Workaround for Adobe Reader XI

Manually adding to the values beneath HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\11.0\TrustManager\cTrustedFolders using a UNC style address gets Reader to correctly fill out the form data.

  1. Run RegEdit
  2. Navigate to HKEY_CURRENT_USER\Software\Adobe\Acrobat Reader\11.0\TrustManager\cTrustedFolders
  3. For each of the sub items (cAlwaysTrustedForJavaScript, cCrossDomain, etc)
  4. Add a new String Value named t[N] (where N is a number higher than the highest number already existing)
  5. Set the value data to the UNC style path (//[SERVERNAME/[FOLDERNAME]) of the folder where the documents will be placed
share|improve this answer
    
This is a comment on the question and not an answer –  ChrisF Nov 14 '12 at 10:35
2  
No. If the only option is that it cannot be done then the only answer is that it cannot be done. –  Clara Onager Nov 14 '12 at 12:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.