Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been tinkering around with Synergy today (Windows Desktop Server, OSX Laptop Client) and I must say I am VERY pleased.

However, I have one issue I need to resolve in order to use Synergy at all.

My dollar-sign (Shift+4) is not working.

The key 4 produces the number "4". Shift+4 produces nothing. Not blank--just no reaction whatsoever.

I have verified that Shift works. Shift works with 1, 2, 3, 5, 6 and so on. Shift+4 works on the host (Windows).

I have also verified that Shift+4 from the actual laptop keyboard works properly.

Obviously, it is not a "Swapped modifiers" issue, since it works with all the other keys. I really need this to take care of the work I do with PHP, so I would be really glad if someone could assist me in troubleshooting the issue.

Here is the Level 1 debug log from synergys

What you see in this debug is me doing several things:

  1. Press Shift
  2. Press 3
  3. Release 3
  4. Press 4
  5. Release 4
  6. Release Shift
share|improve this question
1  
What does the debug log for synergys say? – Josh Aug 8 '12 at 17:53
    
What's happening is when you press shift-3, it sends ASCII code 35 (#). But when you press shift-4, it appears to send ASCII code 164, rather than 36 ($) – Josh Aug 8 '12 at 18:38
    
Can you post your synergy.conf file from the server? – Josh Aug 8 '12 at 18:40
    
I noticed that as well, the numbers seemed a bit off. Not being particularly successful in locating the .conf file, since the host is a Windows machine. Will poke back once I find it! – krystah Aug 8 '12 at 18:45
    
I found no conf-file, but I had an option to save my configuration, so I did that and checked the file, but it only contained basic information on which screens go left, right, their names, etc. Nothing keysym/ascii-specific. – krystah Aug 8 '12 at 18:57

Not sure if it's a solution or a defeat, but I tried out ShareMouse, and it took care of my problems without any hassle. Perfect switching between host/client layouts and easier setup. Yay. :) Thanks for all the help, people!

share|improve this answer

When you press Shift-4, the character code 164 is being sent. This is the Unicode currency symbol ¤, which is often reinterpreted to be a pound £ or euro symbol € by the operating system. This suggests that the computer you're typing on is using a non-U.S. keyboard layout. Try switching the computer to use a U.S. keyboard layout.

share|improve this answer
    
Man, this is messed up. I tried restarting the host after changing the host keyboard layout, and now I am getting the dollar sign, but other characters are messed up. Slash has become 7, etc. Seems like I will not be able to use this program reliably, then! Too bad, I was enjoying it a lot.. – krystah Aug 8 '12 at 19:01
    
Definitely sounds like you have keyboard layout issues. – Michael Hampton Aug 8 '12 at 19:03
    
Sounds like synergy isn't working to me... – Josh Aug 8 '12 at 19:54
    
@MichaelHampton, you know of any keyboard layout in which the slash key produces 7 and there is no Shift+4 at all? o.O – Synetech Oct 12 '12 at 17:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .