Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've recently installed Fedora 17 on my laptop, and I have tried several times to start the MySQL (mysqld) service on it but it refuses to do so. It gives the following error:

[root@blackbird2 michael]# service mysqld start
Redirecting to /bin/systemctl start mysqld.service
Failed to issue method call: Unit mysqld.service failed to load: No such file or directory. See system logs and 'systemctl status mysqld.service' for details.

But, when I go to reinstall MySQL with the yum install mysql command, I get this error:

Package mysql-5.5.25a-1.fc17.x86_64 already installed and latest version

I'm not entirely sure what's going on. I installed Fedora 17 on my PC at the same time as the laptop, and MySQL seems to work fine for that. Has anyone any ideas?

share|improve this question
    
If its an option, have you tried uninstalling MYSQL completely and reinstalling? –  Rhyuk Aug 8 '12 at 19:14

1 Answer 1

up vote 3 down vote accepted

I think mysql rpm only includes client & libraries, but not the server mysqld. Try installing the server with...

# yum install mysql-server

MySQL-server my not be apart of your enabled repos. Here's a guide

share|improve this answer
    
Thanks that's fixed it, but I'm getting a weird thing happen now. When I tell it to start the service it will say "Redirecting to /bin/systemctl start mysqld.service", do nothing, and then display the prompt. It still works, it's just I'm used to it saying "Starting mysqld [OK]". Any ideas? –  mickburkejnr Aug 8 '12 at 19:46
    
@mickburkejnr That's just the way it works now. –  Michael Hampton Aug 8 '12 at 19:59
    
I believe that service ACTION NAMED is aliased to systemctl ACTION NAMED.service, and the redirect notice is a helpful hint about the change. You'll need to do additional MySQL post-install set-up before the "Starting mysqld ... [OK]" will be displayed. –  emcconville Aug 8 '12 at 20:00
    
That's fine, I'm happy as long as it works. Thanks again! –  mickburkejnr Aug 8 '12 at 20:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.