Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Compaq CQ60-215DX that I just took apart to clean out the heatsink (there was piles of dust and dirt)
After putting it back together, and feeling proud that I managed to get it back together, I plugged it in and pressed the power button. The lights on the laptop light up, and I can hear the fan blowing, but I have no video. Just a black screen, not even BIOS.
I tried plugging an external monitor into the laptop, but it just says No Signal. Can anyone help me with this? I already took it back apart and made sure everything was plugged in correctly.

share|improve this question
    
Did you reapply fresh termal paste to the heatsink? Or did if come with a thermal pad? –  Hennes Aug 8 '12 at 19:46
    
I did reaply fresh thermal paste. Cleaned the old stuff off first with isopropyl alchohol. –  Josh Aug 8 '12 at 19:48

2 Answers 2

up vote 2 down vote accepted

Either something is unplugged or you damaged something in the process. It is likely you bumped something during your work. Hopefully you were grounded before you handled any components. Electrostatic damage could be a possibility as well.

Even if they look OK, check all cable and card connections again. The slightest misalignment can cause issues. There is a lot packed into the laptop case and often I find people (including myself) have missed one connector when they think they have gotten them all.

share|improve this answer
    
I did consider ESD, because I didn't exactly ground myself properly. But I want to check everything else I can before I assume that's the cause. Anyways, I checked all the connections, everything seems to be good. Any other ideas before I assume ESD? –  Josh Aug 8 '12 at 19:53
    
Yes. Remove and reconnect all boards and cables again. –  CharlieRB Aug 8 '12 at 19:56
    
Nope, still not working. –  Josh Aug 8 '12 at 20:34

Same thing happened to me. After taking the laptop apart again and checking all connections, it still just had a blank screen. So I took out both memory chips and put only one back in and it booted. I then put the other chip back in and it booted too, so must have just not been seated perfectly before.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.