Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Basically, nobody can establish a connection to anything I host. The website, teamspeak, and game servers. I think it may have something to do with the hosts file or network configuration, but I have tried most things to no avail.

I am running CentOS 6.2 64bit

Edit: I am able to ssh into the server, and I can ping localhost/visit the website through local host, but not through remote connections from another computer. I don't believe it's a firewall because I have never had a firewall running.

Here is a link to relevant information: http://pastebin.com/xRUcr9jE

share|improve this question

1 Answer 1

up vote 0 down vote accepted

First of all, are you running this from home? Big chance is that if you are your ISP does not allow certain connections or has a firewall installed in your router.

EDIT:

Check your iptables

share|improve this answer
    
I am not running it from home. I host small competitive doom servers from a VPS. I do not recall ever installing a firewall, so I think we can rule that out. –  Ivan Aug 8 '12 at 22:36
    
I am very sorry for the stupid question guys. Turns out I had forgotten to flush some IPTables rules I made ages ago. They were dropping connections to my server. Very sorry! Thank you Lucas for making me double-check! –  Ivan Aug 8 '12 at 22:38
    
Actually you can't CentOS comes standard with a firewall called iptables, you might want to issue this command as root: iptables --list –  Lucas Kauffman Aug 8 '12 at 22:38
    
You can accept the answer if it solved your question –  Lucas Kauffman Aug 8 '12 at 22:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.