Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I noticed that autocompletion lists in zsh escape all filenames like this

Age\ of\ Empires\ 2/  ePSXe\ 1.7.0/         Touhou\ Project/      Windows\ 98\ SE/    
Aikisado/             Mathematica\ 8/       Urban\ Terror/        World\ of\ Padman/  

While bash doesn't and shows

Age of Empires 2/     ePSXe 1.7.0/          Touhou Project/       Windows 98 SE/     
Aikisado/             Mathematica 8/        Urban Terror/         World of Padman/  

I'd like to know if there's some way of making zsh behave like this (say, looking like ls --quoting-style=literal instead of ls --quoting-style=escape).

share|improve this question
    
I found this: -Q This instructs the shell not to quote any metacharacters in the possible completions. Normally the results of a completion are inserted into the command line with any metacharacters quoted so that they are interpreted as normal characters. This is appropriate for filenames and ordinary strings. However, for special effects, such as inserting a backquoted expression from a completion array (-k) so that the expression will not be evaluated until the complete line is executed, this option must be used. –  user1002327 Aug 9 '12 at 18:55
    
But I found that in the zshcompctl manual, and as far as I know, the new completion system does not use compctl. If it does, then I don't know where to put this -Q flag in my .zshrc. –  user1002327 Aug 9 '12 at 18:55
    
I got your flag asking to move the question to Unix and Linux, but cannot move the question because it is older than 60 days. If you would like to re-ask the question on that site, you may do so, but please delete this question when you re-post on the other site, or flag it requesting that a moderator delete it for you. –  nhinkle Nov 18 '12 at 6:16
    
Thanks for your answer, will do. To be honest, I didn't know you could delete questions. –  user1002327 Nov 18 '12 at 15:16

1 Answer 1

up vote 0 down vote accepted

Looks like the answer was here:

http://unix.stackexchange.com/questions/13331/in-zsh-how-do-i-hide-the-backslashes-in-the-completion-menu

I couldn't find /usr/share/zsh/functions/Completion/Zsh/_cd, though. I found /usr/share/zsh/4.3.17/functions/Completion/Zsh/_cd instead.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.