Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Mac G5 is presenting me with the power LED flashing two times, a pause and repeats the two flashes. The information I could find states that the memory modules are not present but I have two 512MB modules installed.

I tried replacing the memory with known good memory with and had the same results. I've also replaced the 3.6V battery and the 600W power supply.

Nothing seems to work and my system still can not get past the memory check, no beeps, no gray screen, mo splash screen, nothing. However it will power-up with all the fans turning, and I can hear the hard disk drive movement.

How can I figure out why the memory will not initilize?

share|improve this question

1 Answer 1

This sounds like a logic board failure. Likely the connection between memory and the bus is failing. This happened with G5's due to heat (I speak from multiple experiences). You may be able to find a known good logic board on eBay. As an experiment I once heated a logic board in an oven and reflowed the solder (at least I believe that's what happened). It worked again for a little while. I'm lucky it didn't start a fire. I would not recommend doing that, it's just an FYI. It went down in history as the "Baked Apple" incident.

share|improve this answer
    
Thank you for your responce to my query, you are alot more daring in the DYI department than myself. I think your rigt though, I suspected a problem with a memory controller, but I am going to try a few other things before I throw-in the towl and buy another logic board. Thank you for your insight and example, it has confirmed my suspicions and helped me move in the right direction. –  Michael Lomax Aug 12 '12 at 1:13
    
Latest update to this issue, 8/14/2012. I found one of my known good memory modules I used to trouble shoot my computer was dead. Basically I had to purchace two more memory modules and installed them before the computer system would boot. For now everything working as it should. Thanks again for the help. –  Michael Lomax Aug 14 '12 at 22:01
    
Glad to hear it was repairable. –  Everett Aug 15 '12 at 4:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.