Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Visual C++ 6 is crashing when opening a project or using the "open" file menu,

how can I 'force' VC++6 to work under windows 7 without a Windows XP emulator / virtual machine / Windows XP Mode?

share|improve this question
up vote 7 down vote accepted

To achieve what you want you need proceed with the following instructions:

1) navigate to the installation directory of your VC++6 installation

2) open the /Common/MSDev98/Bin/ folder.

3) Right click on MSDEV.exe and select 'properties'.

4) Select the ocmpatibility tab and select "run this program in compatibility mode for:"

From the dropdown menu select Windows 98/me (Windows XP SP3 works fine too)

5) Check "Run As Administrator"

6) Apply the changes and Fire up MSDEV.exe

7) Select Tools > Options

8) In the editor tab you MUST UNCHECK ALL BOXES in 'Save Options' and 'Statement Completion Options'

9) click OK

10) Select Tools > Options again

11) In the compatibility tab make sure you have "Current source editor emulation:" dropdown box at "Developer Studio"

12) Check ONLY "Enable copy without selection" and "Double-click in dialog editor edits code (MFC only)"

13) click OK

14) Select Tools > Options again

15) In "Workspace" tab make sure ONLY the following items (may be) are checked: "Display Status Bar" , "Output" , "Workspace"

16) click OK

17) Close the IDE

18) Go to you visual C++ installation directory, then to /Common/MSDev98/Bin/IDE/

19) Delete the following file: DEVDBG.PKG (YES DELETE, or AT LEAST move it to you desktop, far, far away from VC++6)

20) Create a COPY of DEVCPP.PKG

21) Rename the created copy to DEVDBG.PKG

22) Have fun using Visual Studio C++ 6 under windows vista / 7 / 8

NOTE: YOU CANNOT USE THE 'OPEN FILE' MENU. You have to load projects by right clicking on the .DSP file (if not associated) and select to open with MSDEV.exe

Some other stuff might not work too, but I at least managed to use the VC++ 6.0 IDE on W7x64 (I can't apply patches somehow :( )

Building some advanced projects works like a charm!

(IF VC++ 6 asks you which of the "two C++" version to use, select the first one!)

Update: The menu crash error can probably be fixed thanks to this article:

if everything done correctly you should have a working version of VC++6.0 in you windows vista/7/8 installation.

Please note that the compiler always works, it's just the IDE which crashes sometimes. (And we tried to fix it now)


If you manage to install SP6 (i installed it in a virtual xp machine then copied the updated files back to my windows 7 host) then even more problems will be gone.

share|improve this answer

Also try disabling "Desktop Composition" and "Display Scaling on high DPI settings". This should fix some issues with some items not refreshing at times, and speed up other processes (like selecting a lot of items at once).

share|improve this answer

For installation on Windows 8 it is important to uncheck Data Access -> Change Options -> ADO, RDS and OLE DB Providers. For more info see the comments to this post:

Visual Studio Installation
1.  Ensure UAC has been turned off.
2.  Ensure your user has administrative rights on the computer.
3.  Run the Setup.exe file in the Visual Studio Installer.
4.  “Run the program without getting help” when the error “This program has compatibility issues”.
5.  Click Next, Accept the Agreement and click Next.
6.  Enter your software key, name and company name. Click Next.
7.  Update Microsoft Virtual Machine for Java.
8.  “Run the program without getting help” when the error “This program has compatibility issues”. Note message shown twice.
9.  Say “Yes” to reboot the system.
10. On start up the setup continues to run.
11. “Run the program without getting help”
12. Start Page shown. Click on Desktop.
13. “Run the program without getting help”
14. Visual Studio 6.0 Enterprise Edition shown with options “Custom, Products or Server Application”.
15. At this point click “Exit” on the installer and confirm with “Yes” otherwise an error will be shown if you continue.
16. Run the Setup.exe file in the Visual Studio Installer.
17. “Run the program without getting help”
18. Click Next and Accept the Agreement and click Next
19. Enter your software key, name and company name. Click Next.
20. Select Custom and click Next
21. Installation folder click next
22. “Run the program without getting help”
23. Click “Continue”.
24. Product ID click “Ok”
25. Tools -> Change Options -> OLE/Com Object Viewer, Uncheck and click OK.
26. Enterprise Tools -> Change Options -> Visual Studio Analyzer, Uncheck and click OK.
27. Data Access -> Change Options -> ADO, RDS and OLE DB Providers, Uncheck.
28. At this point it warns saying the component is essential. Click OK and OK again.
29. Click continue.
30. Say Yes to register environment variables.
31. Say Yes to VSS DB format.
32. Install box with “Destination File:” should appear.
33. Setup is updating your system message box should appear.
34. Click OK to Windows NT Debug Symbols.
35. Click Restart Windows.
36. On start up the setup continues to run and loads APEMREG.exe.
37. Install using compatibly settings.
38. “Run the program without getting help”
39. Untick install MSDN. Click Next and yes to confirm.
40. Select Nothing and click Next.
41. Select Nothing and click next.
42. Untick Register and click finish. 

SP6 Installation
1.  Run setupsp6.exe
2.  Click Continue.
3.  Click I Agree.
4.  Setup Successful click OK.
share|improve this answer

I figured that I would post an update to this since I was having difficulty installing Visual Studio 6.0 even while following the previous steps.

Here are the steps I took to install Visual Studio 6.0 onto my Win7 Pro 32bit system. You should take care to follow these steps exactly and not deviate. The failed installs are due to the outdated DLL files that fail to register. These procedures will help avoid them.

Step 1: Copy the files to a hard drive. A. when copying the second CD, copy them into the same folder as you did CD 1. This will give you a full install setup.

Step 2: Go into each of the folders and set comparability mode for all the .exe files to Windows 98. Also check the disable desktop composition and display scaling on high DPI settings.

Step 3: Run the install program.

Step 4: Select Custom Installation

Step 5: Uncheck 98DCom

Step 6: Uncheck every option except Visual Basic. Ignore any caution messages. As much as people may hate VB, this is the one time VB is your friend. The object of this is to get a successful install.

Step 6: Once you have a successful install, run the Programs and Features program from the control panel.

Step 7: Select the Visual Basic 6.0 program in the list and click the modify/uninstall button.

Step 8: Check only the Visual C++ option to add Visual C++.

Step 9: Run the Visual Studio 6.0 Service Pack 6 program. This should fix the open file crash.

Step 10: Enjoy using Visual Studio 6.0 on Windows 7.

Scott Tovey

Update: The VB6 Service Pack 6 prevents the open file crash but you must run Visual C++ as Administrator.

share|improve this answer

You must log in to answer this question.