Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The Windows Experience Index (WEI) Rating / Windows System Assessment Tool (WinSAT) on my system aborts with an error message. All tests are run, the XML files in %systemroot%\Performance\WinSAT\DataStore are generated, but nothing is displayed in the control panel.

When run from the command line the error message is

Error in saving results to the datastore            winsat\main.cpp(4735)

What's wrong?

Update: For some, the solution seems to be deactivating Kaspersky. However, I don't have (and never had) Kaspersky installed. My Win 7 Ultimate is freshly installed and activated and has the same problem.

share|improve this question
Is this the RTM or RC version? – A Dwarf Sep 23 '09 at 23:49

it's RTM, I'm having the exact same issue. The only problem that I can think would be preventing my WEI is the fact that I have no cdkey or activation completed, due to the fact I'm waiting on my replacement key from microsoft.

Any suggestions?

share|improve this answer
Yes, it's RTM and I also haven't it activated yet. However, right after installation it worked, so I don't think that is the cause of the problem. Just when I replaced the video driver provided by Windows Update with a more recent version by nVidia the old index numbers got invalidated but I couldn't save newer ones. But as I also installed other drivers in between I couldn't really put my finger on anything... – Henning Oct 4 '09 at 15:44

solved. it's kaspersky Kis. uninstall it reboot, run winsat, then re-install kis. works fine now. found it on russian forum

share|improve this answer

I have a slight variation on this problem. Windows 7, x64, no kaspersky or any other virus scanner installed. Windows is a fresh install of RTM, with all patches / updates applied.

When I first installed 7, it ran the index and gave a nice score. Now, for some reason the Rating area of system properties is blank (the part just above the processor name / type).

When I go to the Performance Information and Tools section it says "Your Windows Experience Index has not yet been established." and there is a button labeled "Rate this computer" next to it.

When I click on that button absolutely nothing happens. No dialog boxes, no errors, nothing.

If I look in the c:\windows\performance\winsat\datastore directory I see the assessment information from the initial install.

There are two things I can think of. First, the video drivers were updated by Windows Update. I have a pair of ATI Radeon 4670s driving 3 monitors, not in crossfire mode.

The other thing I can think of is that I attached the machine to a CyberPower UPS. I may try taking it off of the UPS, but if being on a UPS throws the score out it would kind of defeat the purpose.

share|improve this answer

For those finding this error and not having Kaspersky installed the following worked for me.

  1. Right click on the %systemroot%\Performance\WinSAT\DataStore folder and uncheck read-only.
  2. Delete the the contents of the folder.
  3. Run commandline as administrator
  4. Enter "winsat formal forgethistory"

This will run the performance check in console and for me it completed. Since then I have been able to Re-run the assessment via My Computer properties.

FYI I didn't have a serial entered, RTM, but even after I did it wouldn't successfully run the index via properties until I did the steps listed above.

share|improve this answer

I faced this issue in W7 on a Toshiba Satellite with ATI Radeon X1200. UI just said an error occurred due to driver or system error, but the commandline gave the same error saving to datastore error. After knight-gkla note, I uninstalled Kaspersky 2010, and it solved the error. Thanks!!

I am new to Superuser so I can not vote up..:(

share|improve this answer

have a look at:

This should solve the problem.

share|improve this answer

I had this problem, but I had also gone in the registry to change my default Programs File location. I changed it back to C:\Program Files and I was able to rerun my experience index. If you've messed with the registry any, you may want to check that.

The location of the key I changed was HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\ProgramFilesDir

Along with others that referenced the C:\Program Files and C:\Program Files(x86) folders.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .