Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Whenever I insert a USB drive in my desktop PC running Windows 7 Ultimate, it becomes write protected. Then when I use it on my laptop, I can't delete the files on it.

I already tried scanning for malware and viruses.

Can I repair this, eventually without reformatting?

share|improve this question
    
I dont know what to do. I tried scanning, there is no virus. no malwares. –  Bazinga Aug 9 '12 at 12:53
    
I mean, you said you searched on Google and "followed what they said". So by that, you meant a virus scan? –  slhck Aug 9 '12 at 12:54
    
What i search was also to repair the usb from not being write protected. –  Bazinga Aug 9 '12 at 12:55
    
Are you saying you can format the drive to make it writeable again? If not, then please see this... the drive may be a lost cause. In any case, copy all the data off the drive now. –  Bob Aug 9 '12 at 13:05
    
So I need to reformat my desktop PC? –  Bazinga Aug 9 '12 at 13:08

4 Answers 4

This either happens by the hardware lock or a software setting:

  1. You have write protected the USB drive by sliding a lock.

    To resolve this, you can slide it back to be unlocked. Use tape if you accidentally lock it.

  2. Your storage device policy is set to be write protected.

    To resolve this, open up the registry editor (Start -> Run -> regedit) and browse to HKEY_LOCAL_MACHINE\SYSTEM\CurrrentControlSet\Control\StorageDevicePolicies, there you can create / edit a new DWORD called WriteProtect and set the value to 0.

    If StorageDevicePolicies doesn't exist, you can safely create that registry key as well.

Check the latter on both your desktop and laptop.

share|improve this answer
    
Have tried it. But, for example. from my laptop I copy a file in my usb. then in my desktop pc, it became corrupted when I access it. I think the prob is in my desktop. –  Bazinga Aug 9 '12 at 13:48
    
@user1302274: Sounds like you are not doing safe removal? –  Tom Wijsman Aug 9 '12 at 13:51
    
Im doing safe removal. –  Bazinga Aug 9 '12 at 13:52

Insert USB drive

  • go to Computer
  • Right click the USB Drive icon and click Properties
  • Click the security tab.
  • Click edit under the Group or user names display.
  • Click on Everyone (so that it is highlighted) then below in the permissions for Everyone area, tick Full Control.
share|improve this answer

Works except in windows 7.

  1. Right-click the USB drive icon then select Properties.
  2. Go to Sharing > Advanced sharing.
  3. Tick Share this folder
  4. Click Permissions.
  5. Select Everyone.
  6. Check Allow under Full Control.
  7. Click Apply > Apply > Close.
share|improve this answer

Open up a console (cmd.exe) and type diskpart. Type list disk then select disk 0 (change the 0 to whatever number your USB drive is. Type detail disk and check the "Current Read-only State" and the "Read-only" attributes. If it says "No" for the first and "Yes" for the second, your USB drive may be going bad. If it's the other way around, then it's a policy/program messing with it. If this is the case, back up your files on the USB drive, open up another console and type (again, replace the 0 on select disk 0 with your USB drive number):

diskpart
list disk
select disk 0
clean
create partition primary
format fs=FAT32 quick

Safely remove the USB drive and try it again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.