Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I previously used cwRsync to backup files from WIndows XP to a Linux server

Now I am trying to use cwRsync on a Windows 7 PC (64-bit) to backup to a different Linux server

I installed the free version of cwRsync and set up the environment as in the included cwrsync.cmd except I set CWRSYNCHOME=%PROGRAMFILES(X86)%\CWRSYNC as that's where cwRsync installs on 64-bit Windows.

I can ping the Linux server by name and I can resolve it's IP-address using nslookup but when I run rsync I get an error message

C> ssh -V
OpenSSH_5.3p1, OpenSSL 0.9.8l 5 Nov 2009

C> rsync -rvz cygdrive/d/Foo xxxx:/home/RGB/Bar
ssh: Could not resolve hostname xxxx: Non-recoverable failure in name resolution
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: error in rsync protocol data stream (code 12) at io.c(610) [sender=  3.0.7]

cwRsync includes both ssh and plink in it's bin subdirectory. WHen I run ssh directly I get the same error. However if I run plink directly it connects OK.

  • Is there a way to get rsync to use plink?
  • Is there a way to get cwRsync's ssh to resolve hostnames correctly?
share|improve this question

1 Answer 1

If this software respects system-level host information, you could edit the system host file:

  • C:\windows\system32\drivers\etc\host

It may instead honor your Cygwin host settings:

  • ${cygwin_root}\etc\hosts

Try editing one or both of these files to include the remote host's IP address and name:

1.2.3.4 hostname

Be careful not to delete or overwrite any existing name/IP pairs. Also your anti-virus/malware software (if any) may prevent changes to this file, in which case you may need to authorize the change or temporarily disable the software until after the change.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.