Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded my Debian recently and now in Youtube, all the flash videos are pixelated. Example:

enter image description here

I have tried both methods from here: Disable hardware acceleration for Flash player in Linux

I have

  • Fullscreened a youtube video, right click settings, disable hardware acceleration. Restarted numerous times, nothing.
  • Did #1 except without fullscreen
  • Created the /etc/adobe/mms.cfg file with

EnableLinuxHWVideoDecode=0

It's been nearly two weeks, and I'm sick of watching videos like this.. any help appreciated :)

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Have you checked to see if you have the latest Flash add-on and that your Browser is up to date?

Flash is one of those special free add-ons that licensing needs to be agreed to before it's actually installed (it's a legal thing if you're wondering). But if you're using something like Chrome then you may not even be using Flash (same goes if you use Chrome to view PDF documents too). However, other browsers need the Flash add-on to view YouTube content as well as many other online video services.

Then again, are you sure you're not viewing an HTML5 video or possibly trying to use a different add-on?!

This is why it's so important to include as many details as you can - particularly which browser you use as I seem to recall Debian uses something like Konquorer by default which is not a very standard web browser. That said...

If it were me, I'd try installing a different web browser like Firefox. Then check the repositories to make sure all updates for the latest Firefox are correctly allowed as well as allowing the latest Flash add-on too. (I might even allow Java if I had any real need for that as well). Then about all that's necessary would be to make sure that the latest updates are downloaded and applied. Of course, it's possible to do this by hand too. But doing it by hand is much more of a PITA, if you ask me - particularly since you need to check quite often.

Then again, what I saw would seem to indicate a (video/system) RAM problem or possibly a simple video driver problem. So have you checked to make sure you have the latest video driver? Have you looked at your BIOS settings to make sure RAM timing or even PCIe settings weren't messed with?

It could instead be a CPU problem or even something as simple as cable interference too (which can happen). Therefore, you may want to check all hardware, clean out the dust bunnies, re seat cards and RAM and possibly reroute VGA cables away from any high voltage transformers such as those used in fluorescent lights. I can't say if that's the problem but it's always good to check.

share|improve this answer
    
Wow, I don't know how I forgot to mention it's Chrome.. I'll add more details. –  meder Aug 9 '12 at 19:09
    
I followed helpx.adobe.com/flash-player/kb/… and enabled Flash in about:plugins –  meder Sep 18 '12 at 5:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.