Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've got an issue with compiling vim. I keep getting a missing tlib error... but I have libncurses5 installed.

$ ./configure --prefix=$HOME/opt     --enable-multibyte     --with-tlib=ncurses     --enable-pythoninterp     --enable-rubyinterp     --with-features=huge
# ... bunch of other checks ...
checking --with-tlib argument... ncurses
checking for linking with ncurses library... configure: error: FAILED

$ sudo dpkg -l | grep ncurse
ii  lib32ncurses5                                               5.9-6                           shared libraries for terminal handling (32-bit)
ii  libncurses5:amd64                                           5.9-6                           shared libraries for terminal handling
ii  libncursesw5:amd64                                          5.9-6                           shared libraries for terminal handling (wide character support)
ii  ncurses-base                                                5.9-6                           basic terminal type definitions
ii  ncurses-bin                                                 5.9-6                           terminal-related programs and man pages

$ sudo apt-get install libncurses5-dev
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libncurses5-dev : Depends: libncurses5 (= 5.9-4) but 5.9-6 is to be installed
                   Depends: libtinfo-dev (= 5.9-4) but it is not going to be installed
                   Depends: ncurses-bin (= 5.9-4) but 5.9-6 is to be installed
E: Broken packages

Can someone advise me on how to resolve this issue? All I want to do is compile VIM with python & perl support.

share|improve this question
add comment

1 Answer

Maybe update your package databases. The error message says that libncurses5-dev (which do you want install) is too old (its version is 5.9-4 and you've ncurses binaries version 5.9-6).

The version (and release) of devel package should equal with version (and release) of binaries.

Or try downgrade the installed binaries.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.