Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Similar to this question, except I'm on Windows 7. That question also has no accepted answer, and the answer doesn't work for me.

I've tried all the different "Output Module" settings in the Audio section of the preferences in VLC Player, and still the sound comes out of my PC speaker instead of the 3.5mm audio jack, where my headphones are plugged in.

Headphone audio output works fine for every other application I've used, including Windows Media Player.

How can I get VLC Player to send its audio output to my headphones instead of to the PC speaker?

share|improve this question
    
For both Mac OS and Windows 7, you have to makes sure that you have the USB headset driver installed and loaded. –  Alex W Aug 10 '12 at 1:35
    
@AlexW, I'm not using a USB headset, just the 3.5mm audio jack. Would it still make a difference? –  Highly Irregular Aug 10 '12 at 1:40
    
Sorry, I didn't notice that this problem was unique to VLC. –  Alex W Aug 10 '12 at 1:51
    
It may be a bug: trac.videolan.org/vlc/ticket/6510 You can try closing VLC, plugging in headphones, and then opening VLC. –  Alex W Aug 10 '12 at 1:52
    
Thanks for your help @AlexW... I found a solution, so I've posted it. –  Highly Irregular Aug 10 '12 at 2:00

3 Answers 3

Just had same issue and for me and after pairing my device used these steps :

Select :

Control Panel -> Sound -> Manage Audio Devices

Under Playback tab set bluetooth device to default :

enter image description here

share|improve this answer

My problem was in Win7. and solved this way. Click On Speker icon on system tray, then on Mixer then surprise sound disabled for specific application in case VLC. (I muted it before and forget to reset.)

Hope this helps someone.

share|improve this answer
up vote 5 down vote accepted

This solution (from here) resolved the issue:

  1. Open Tools/Preferences and at the bottom of the list,under "Show settings" switch from Simple to "All".
  2. Under Audio, Expand and select "Output module" and change Audio output module to "Win32 waveOut extension output".
  3. Under "Output module" select "Waveout".
  4. Select Audio Device. In the dropdown, select your output used for your headset and click save.
  5. Restart VLC.

Note that in my case the restart of the VLC application was definitely required! It may also mean that when I previously tried various different settings without restarting VLC, the changes may actually have worked after restarting VLC.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.