Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question is rather esoteric, but an hour of net-perusing led me nowhere useful.

I am attempting to get an old Evolution ER1 robot kit (no longer produced) running on Windows XP. The install CD which came with my kit did not work on two separate systems (was just read as a blank CD), so I used the CD image found here. The Robot Control Center installed fine, and I got the camera working fairly easily, but no matter what I do, the Robot Control Center program will not recognize the USB robot control module; it gives a Error accessing robot hardware message upon startup and is nonfunctional.

There are two devices involved here: a USB to serial converter (sometimes called a USB serial port) and the robot control module. They require separate drivers.

The Evolution Tech Support FAQs suggest manually installing the drivers. The instructions make sense (and seem reasonable), but the files they list simply do not exist in that folder. The instructions state to (excerpts):

6) Click "Have Disk..." and "Browse" to the location of the driver (D:\USB Robot Control Module)

7) Highlight the "ER1 Control Module v1.0" in the list and click the Next button.

and

7) Click "Have Disk..." and "Browse" to the location of the driver (D:\USB Robot Control Module)

8) Highlight the "USB Serial Port" in the list and click the Next button.

9) When prompted by the driver-signing wizard, click "Continue Anyway".

for the control module interface and USB to serial converter respectively.

However, my "USB Robot Control Module" folder has only the following drivers:

ftdibus.inf, FTDIPORT.inf, and FTDISERMOU.inf.

Simple deduction would suggest the first two are for the USB to serial converter and the latter for the robot control module, but installing as such doesn't work, nor does the reverse, or any other configuration I tried. No matter what I do, the Robot Control Center software gives the same Error accessing robot hardware message upon startup, and all commands are nonfunctional.

At this point, I'm not sure where to go. If someone who has gone through this process could give some pointers, they would be very much appreciated.

share|improve this question
    
FTDI is a maker of USB to serial adapters, FTDISERMOU sounds like a serial mouse driver - not a robot control module driver. Are there no other drivers anywhere else on the CD? –  RedGrittyBrick Aug 10 '12 at 7:52
    
@RedGrittyBrick Sorry, I should have clarified. As that driver seemed unrelated to a USB to serial port, I concluded it must have to do with the other device. It seemed reasonable to me that Evolution would reverse engineer or use a modified driver for a serial mouse to interface with a serial robot control board. –  BinaryMage Aug 10 '12 at 7:54

2 Answers 2

Sorry to send you away but try these https://inet.idealab.com/dbd/A8ACB584/ER1_CD.zip https://inet.idealab.com/dbd/756A30AB/ER1_Updates.zip

These links are form http://www.societyofrobots.com/robotforum/index.php?topic=5904.0 forum; in-fact there are other links which may be useful but it appears the above 2 is the original CD and the updates. I hope this helps although there is no mention of what OS this is for (XP or even Windows for that matter).

share|improve this answer
    
The CD image you linked is the one I used, linked from this page mentioned in my post. It's actually not the original image; it installs RCC 1.2.0.127. The "Updates" archive contains files to update to that version, which unfortunately won't help me. –  BinaryMage Aug 10 '12 at 8:34
    
Sorry, I didn't see your link (the screen colour on my screen made it hard). Sorry. –  Dave Rook Aug 10 '12 at 8:36
    
No worries; thanks for your answer nonetheless! –  BinaryMage Aug 10 '12 at 8:37
up vote 0 down vote accepted

Error accessing robot hardware is (cryptically) a general error code that could result from different things, not solely driver issues.

In this case, it turned out the battery was defective; using a different power source fixed the problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.