Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I try to print my Sourcecode from Visual Studio 11 RC, the Code gets printed as white on black, not the other way around. I tried searching for it in Enviroment- Colors- Printer, but I don't see anything wrong there.

The header of the pages is fine, just the code is wrong.

I use a dark skin, but that shouldn't make a difference for the printing? I also tried "Use Defaults" in the color settings for Printer and Text-Editor.

EDIT: It seems to work now if I choose the light skin and restart VS. If I switch back to the dark skin, it again doesn't work.

share|improve this question
Does it happen to all file types (*.cpp, *.h, *.cs, *.pas, *.txt...)? Did you try to print to pdf, for example to PDFCreator? Did you reset settings (tools > import/export settings > reset)? – kokbira Aug 10 '12 at 15:53
See my edit. I tried resetting the settings, no luck. Yes, I tried printing to pdf. – Juri Robl Aug 10 '12 at 15:55
Nice to know you found a way to print, although you could not do it on dark skin... – kokbira Aug 10 '12 at 20:39
No, I use the windows standard skin. Notepad printing works fine, no wrong colors there. – Juri Robl Aug 10 '12 at 20:41

1 Answer 1

up vote 6 down vote accepted

I don't know if you are still interested in finding an answer to this, but it looks like in Visual Studio 2008 at least you can set the printing format separate from the text editor format by going into the settings.

go to this link How to: Print Code in the Editor under the section labeled color printing it points you to another link Fonts and Colors, Environment, Options Dialog Box where it tells you how to set the printed output format separately from the Text Editor code.

I am unsure about the version that you are using, if these same options are available or not in the toolbar menus.

in Visual Studio 2010

  • Tools
  • Options
  • Environment
  • Fonts and Colors

then it will look like this.

Options Dialog

and you can choose the print option and set everything to the normal Visual Studio "Light" theme

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.